Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
ainar-g
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
55 ms
·
571.
▲
by
ainar-g
8y ago
Oh, that's a good one. Also W3C documents.
572.
▲
by
ainar-g
8y ago
Some examples of what I consider timeless (and good) UI on the internet: * Hacker News (duh) * c2 wiki * Wikipedia (it changes, but thankfully not radically) I would have added Reddit, but alas. Seeing how they plan to change to that... oth
573.
▲
by
ainar-g
8y ago
IMHO: * Merge Patch better reflects the practices that people are already using today. * RFC 6902 is over-engineered and less understandable. * RFC 6902 requires more space. * RFC 6902 requires another RFC[1] to work. RFC 6901 - JSON Pointe
574.
▲
RFC 7396 – JSON Merge Patch
(tools.ietf.org)
2 points
by
ainar-g
8y ago
|
3 comments
575.
▲
by
ainar-g
8y ago
I guess I needed to be clearer there. I meant experienced programmers in Moscow, Russia. For the most part it's either one Skype call (<= 30m) and one personal interview (1h - 1h30) or two personal interviews. There are exceptions t
576.
▲
by
ainar-g
8y ago
>So if you come on site with us, you're going to have four sessions. That’s our ‘right’ number, because we don’t want to ask too much time from candidates and be grueling, but we also need to have enough data points. The four sessio
577.
▲
by
ainar-g
8y ago
I thought the legacy of Modula-3 lives in OpenJML (through ESC/Modula-3 -> ESC/Java -> ESC/Java2 -> OpenJML)? I have never heard anyone use it though.
578.
▲
Minimal working examples of Rust's unique features
(github.com)
4 points
by
ainar-g
8y ago
|
0 comments
579.
▲
Another one bites the Rust
(tenfourfox.blogspot.com)
4 points
by
ainar-g
8y ago
|
0 comments
580.
▲
by
ainar-g
8y ago
Did you mean to write "Venn diagram", or this was the joke?
581.
▲
The Strict Aliasing Situation Is Pretty Bad (2016)
(blog.regehr.org)
1 points
by
ainar-g
8y ago
|
0 comments
582.
▲
by
ainar-g
8y ago
See also, the Rust container infographic[1], and the /r/rust thread about it[2]. [1] https://i.redd.it/moxxoeir7iqz.png [2] https://www.reddit.com/r/rust/comments/74yrdp/rust_co
583.
▲
by
ainar-g
8y ago
Wikipedia link: https://en.wikipedia.org/wiki/Romansh_language . Sample (from The Fox And The Crow): La vulp era puspè ina giada fomentada. Qua ha ella vis sin in pign in corv che tegneva in toc chaschiel en ses
584.
▲
by
ainar-g
8y ago
Do you foresee an enlargement in the total number of speakers? Why? Also, if I got it correctly, Romansh is one of Switzerland's national languages, so theoretically one could move to Graubünden and acquire Swiss citizenship through Ro
585.
▲
by
ainar-g
8y ago
It will be really funny if there is some bit of new, undiscovered physics, that went undiscovered for so long just because it's best described using some esoteric maths like complex base numbers. Highly unlikely, but fun to think about
586.
▲
by
ainar-g
8y ago
For those wondering, please do read the Wiki article[1]. It's amazing. [1] https://en.wikipedia.org/wiki/INTERCAL
587.
▲
by
ainar-g
8y ago
Counter-examples: * C++ uses bitshift operators for IO. The (in?)famous std::cout << "hello world" << std::endl; Which is such an improvement over puts("hello world"); * Ruby on Rails comp
588.
▲
by
ainar-g
8y ago
This is rather off-topic, but I want to learn Idris or any other purely functional programming language one day to the point where I would be able to read any program, but most programs written in those languages are so terse and abstract,
589.
▲
Quote O' the Week: It’s [Not] Faster Because It’s C (2010)
(maniagnosis.crsr.net)
1 points
by
ainar-g
8y ago
|
0 comments
590.
▲
by
ainar-g
8y ago
I wonder if the lack of strongly statically typed embeddable languages is due to an accident or a fundamental limitation of implementations of such languages. Is the type checker code too big? Is it too complex?
591.
▲
by
ainar-g
8y ago
In Go, one has to always write the if-else bodies in curly braces (and, the opening brace should always be on the same line). I think this is great for two reasons. Firstly, it prevents bugs where a very tired programmer needs to add someth
592.
▲
by
ainar-g
8y ago
I see your point, although I would probably use something like mruby[1] if I wanted something embeddable and OO. [1] http://mruby.org/
593.
▲
by
ainar-g
8y ago
Don't we have already Lua for that? It even has a state-of-the-art JIT compiler. I am all in for competition, but I can't see how both of these languages could improve over Lua.
594.
▲
by
ainar-g
8y ago
>null >dynamic typing >naked if-else bodies I'm sorry, but I just don't see how this improves on anything. How will GravLang make me a better, more productive programmer? How will it make my programs more robust? Don'
595.
▲
by
ainar-g
8y ago
According to the Wiki, the original UTF-8 proposal used up to 6 bytes.[1] But the Unicode standards people decided that 21 bit should be enough for everyone: >Since the restriction of the Unicode code-space to 21-bit values in 2003, UTF-
596.
▲
by
ainar-g
8y ago
I agree that that point sounds too rough. I would write something like >Every software has issues; so know your software's gotchas. With that said, the perception I get is that PostgreSQL has less such gotchas and works better &qu
597.
▲
Notes on WASM in Go 1.11
(blog.owulveryck.info)
2 points
by
ainar-g
8y ago
|
0 comments
598.
▲
by
ainar-g
8y ago
Recently I talked with my cousin, who is also a software engineer, about dependent types, contract programming, invariants, and all that. Among other things I've told him about "type-safe printf" that you can write in Idris.
599.
▲
by
ainar-g
8y ago
What upsets me the most is the fact that Firefox Developer Tools still have no built-in way to inspect WebSocket frames. It's one of the few reasons I use Chrome these days.
600.
▲
by
ainar-g
9y ago
I would prefer compilers that produce compact statically linked "binaries".
More ›