Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
niftich
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
81 ms
·
631.
▲
by
niftich
9y ago
The problem is, content delivered over the web "leaks out" in standard usage and interfaces with the overworld, unless prevented by DRM. People save files, sometimes using contrived workflows, and content that was transferred to a
632.
▲
by
niftich
9y ago
Roughly, BPG [1] is for HEVC as what WebP is for VP8 or VP9, in the sense that you take an I-frame out of a video format and stuff it into an established, classic image container. Compared to this, HEIF is a different way of packaging HEVC
633.
▲
by
niftich
9y ago
This seems conceptually most similar to Fabrice Bellard's proposal 'BPG' [1], which was essentially a lightweight wrapper around an HEVC I-frame. The format got small amounts of attention in encoding circles, but didn't
634.
▲
by
niftich
9y ago
It wasn't for the first JVM; it was for HotSpot, the JIT engine that replaced [1] Sun's previous JVM in 1999. HotSpot was developed by the same team that worked on Strongtalk [2], including the linked submission's author Brac
635.
▲
by
niftich
9y ago
What do we mean by 'documentation'? Usage of the outwardmost-exported interface (which, depending on the project, may be an UI or an API)? Configuration and customization options, installation instructions? Design rationale, deep-
636.
▲
by
niftich
9y ago
They were logged during the mid-1800s as SF and Oakland were growing and the gold rush was going on, then again after the 1906 earthquake. Essentially no old-growth trees remain (one, I think?); but a stand of younger redwoods does still ex
637.
▲
by
niftich
9y ago
It's unfortunate that the 'bar' in misuse-resistant crypto isn't always equally high, and different experts (as evidenced from this thread) argue that you get there in different ways. In that regard, I think the author m
638.
▲
by
niftich
9y ago
Look, there's no dispute that Facebook is an assault on the 'open web' because it's a walled garden where the data only flows in. In fact, on the HN thread for Gruber's previous post about Google's AMP, I defen
639.
▲
by
niftich
9y ago
Which "good" ciphersuites [1] were usable in TLS 1.0 when BEAST was made public in June 2011; with BEAST affecting only TLS 1.0? TLS 1.0 per RFC 2246 defined DES40_CBC, DES_CBC, 3DES_EDE_CBC, RC4_40, RC4_128, and IDEA_CBC. RFC 413
640.
▲
by
niftich
9y ago
Midnight Commander and its spiritual predecessors going all the way back to Norton Commander and Volkov Commander are marvellous examples of TUI. They're intuitive, interactive, come with embedded help, and use text mode to present a s
641.
▲
by
niftich
9y ago
I'd guess that a road like Dalton where weather-related and road condition-related hazards can suddenly appear, would make an exceedingly poor fit for self-driving non-guideway vehicles. Far better would be vehicles -- self-driving or
642.
▲
by
niftich
9y ago
See also, the de-obfuscation wrapper [1], decryption implementation [2], and the key [3]. [1] https://github.com/ncw/rclone/blob/66e8c1600ec8c18cbcdce5664... [2] https://github.com/ncw/rc
643.
▲
by
niftich
9y ago
In a comment of mine earlier this week [1], I (along with others) speculated whether the shipping of OAuth2 secrets was the reason for the ban, and whether they're other contributing, strategic factors. I wrote: Amazon has revoked rcl
644.
▲
by
niftich
9y ago
This has been asked for a long time [1]. One view is that they wouldn't pass it, because, in their (lawyers') own words: Although software applications for the Android platform may be written in the Java programming language, the
645.
▲
by
niftich
9y ago
I meant to provide a citation for the claim that Sun was in favor of copyleft. I'm basing this on the 2007-08-09 blog entry [8] by Rich Green, then Executive VP of Software at Sun [9], which uses the word 'copyleft' explicitl
646.
▲
by
niftich
9y ago
This saga goes back to Sun Microsystems and Apache Harmony. Harmony, as originally announced was to be an Apache 2.0 License cleanroom reimplementation of the Java platform, complete with the standard library and a VM [1]. There was a lot o
647.
▲
by
niftich
9y ago
To be fair, Oracle released Java 7 and especially Java 8 with a bunch of goodies and improvements that increased productivity and brought new paradigms to the language in an elegant way (considering it's still Java). But Google already
648.
▲
by
niftich
9y ago
A little bit before 2017-05-21T00:52Z [1], moderator sctb updated [2] the submission's URL from the original blog post by John Gruber [3], to that of an article in The Register penned by Scott Gilbertson. Gruber's post quotes Gilb
649.
▲
by
niftich
9y ago
AMP pages don't intrinsically live on google.com. Rather, when you use Google Search on mobile, some results may have AMP equivalents, they're often prioritized on or closer to the top [1] or otherwise highlighted (like in a carou
650.
▲
by
niftich
9y ago
The complaint about AMP's strange UX paradigms is valid: it works very hard to pretend like every AMP article is a standalone website, but it actually behaves like a viewport-wrapping iframe, where Google Search is on the outside and t
651.
▲
by
niftich
9y ago
Tesla in Fremont at the old GM/NUMMI plant; Flextronics in Milpitas, and a few smaller ones, but pretty much all on the east side of the bay. A Forbes article [1] on this from 2012. [1] https://www.forbes.com/global
652.
▲
by
niftich
9y ago
Link as originally submitted leads to a commit message where the submitter, maintainer of git-annex-remote-rclone, a tool which wraps the multi-provider cloud storage client rclone [1], makes the following comment: "Amazon has, withou
653.
▲
by
niftich
9y ago
This paper -- the CRLite proposal -- is wonderfully well thought-out, experimentally tested, and meets the design goals much better and more elegantly than any other attempt to solve the certificate revocation problem. Looks like it was pos
654.
▲
by
niftich
9y ago
This is the pull request that triggered today's issue [1]. They introduced a custom object that overrides Go's default ServeMux, such that their code won't collapse adjacent slashes, unlike Go's default. They did this be
655.
▲
by
niftich
9y ago
They probably are . But some applications will decode the percent-encoding too early in the process of normalizing, security-escaping, and processing the URL. Encoded slashes in URLs are problematic [1][2][3][4][5]. [1] https://
656.
▲
by
niftich
9y ago
Josh referred to RFC 6960 Appendix A, but his post didn't make it apparent that his description of is an exact quote from the spec [1]: An OCSP request using the GET method is constructed as follows: GET {url}/{url-encoding of
657.
▲
by
niftich
9y ago
Some have argued that this is why CRL and (especially) OCSP are useless pieces of security theater: they don't actually protect against a crafted attack because they fail-open in the very situations that a determined adversary can trig
658.
▲
by
niftich
9y ago
The JVM isn't actually slow to start [1] (albeit it does start about 3x-4x slower than python, ruby, or node) [2]. Most of the slow startup in a JVM-based application is in classloading [3] or waiting for your chosen framework to initi
659.
▲
by
niftich
9y ago
The terminology for "native" used in the blog post is inexact (actually, incorrect), but consistent with how the casual usage of the term has drifted due to the competition from the 'web technologies' stack. In this usag
660.
▲
by
niftich
9y ago
A month ago on the thread about AWS opening up a region in Sweden, a discussion ensued [1] about the lack of major cloud provider datacenters in Africa. I wrote [2] that a good site in Africa would be challenging, because one would have to
More ›