Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
baudehlo
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
41 ms
·
421.
▲
by
baudehlo
13y ago
That doesn't deny the call. It just turns the ringer/buzzer off until they give up.
422.
▲
by
baudehlo
13y ago
The domain outlok.com has an A record which points to 208.87.35.108 which I can even connect to on port 25 (though I don't perform that test). Until you actually mail that address there's no way to distinguish this from a valid email.
423.
▲
by
baudehlo
13y ago
It's my MTA, I'm the "user". My server, my rules. Just like if you want to come into my house you come in the front door and take your shoes off, not crash through the window in muddy boots.
424.
▲
by
baudehlo
13y ago
My MTA doesn't "throw away" email. It sends back a 5xx with an appropriate message that the sending end isn't RFC compliant. Absolutely nothing wrong with that - if it's a legit sender they know I didn't get the mail.
425.
▲
by
baudehlo
13y ago
Postfix (and the other big receivers) will ignore it, but will send using the proper RFCs. It's still a good sign of a badly written bulk mail engine, and worth rejecting for.
426.
▲
by
baudehlo
13y ago
Hopefully that's not the SMTP syntax you're actually using. * There's no space between FROM: and the address in SMTP * Email addresses must come between angle brackets I'd reject (give you a 5xx) that from my mail server for th
427.
▲
by
baudehlo
13y ago
The only thing mailcheck doesn't do is check if the domain has MX records, so valid looking domains that you'll never be able to send anything to will pass. I've tried to help this situation by creating an API for you guys: https://www.ema
428.
▲
by
baudehlo
13y ago
There's nothing wrong with doing full validation. Just don't use that regexp - it's for RFC822 email addresses, which is how you might see them in an email header, including things like comments. You want an RFC821 (or more specifically RFC
429.
▲
by
baudehlo
13y ago
This has come up so often on Hacker News that I decided to create a very simple JSON API for checking email addresses. Free to use for anyone. Performs the right regexp check for email addresses based on RFC-5321 rules (not the oft-quoted b
430.
▲
by
baudehlo
13y ago
Please don't quote that RFC-822 regexp when arguing this. That's for the contents of mail headers (which can include comments and so on), not an actual valid email address. A regexp for validating RFC-2821 email addresses is actually fairly
431.
▲
by
baudehlo
13y ago
DBD::SQLite remains one of my greatest successes - so glad you like it. So many projects I have prototyped using SQLite (although for most I later upgrade to PostgreSQL). Such a great little tool, and building DBD::SQLite the way I did (inc
432.
▲
A simple JSON API for validating email addresses
(emailitin.com)
2 points
by
baudehlo
13y ago
|
0 comments
433.
▲
Paint your walls with ideas
(blog.hubdoc.com)
2 points
by
baudehlo
13y ago
|
0 comments
434.
▲
by
baudehlo
13y ago
The problem is that adds to your weight. Not important if you're car camping, but important for hiking.
435.
▲
by
baudehlo
13y ago
Thanks. As much as I hate to be "that guy", I think it's also important that people don't invest in a product on kickstarter that isn't going to match expectations, or isn't the "brand new innovation" that they say it is. Just for further i
436.
▲
by
baudehlo
13y ago
It is more expensive but only because it has an R value of 8.0 (the Kickstarter one has an R value of 1.0, which means it's not going to give you any protection from the cold ground whatsoever - even a self-inflating pad gives you more prot
437.
▲
by
baudehlo
13y ago
I'm afraid there's already a matress that does this. It's from exped, I own one and it's awesome, and better implemented than this because you're only inflating a small pump sack, and can use it to build pressure in the mattress. Here's a v
438.
▲
by
baudehlo
13y ago
The problem is they don't accept PUT or POST without a content-length and email attachments don't give you a length up front.
439.
▲
by
baudehlo
13y ago
If you're at your desktop, absolutely it's easier to use your synced folder. But what if you're on someone else's computer? Or on mobile? Or just have an email someone sent you. If you go over the size limit you will get a bounce message. I
440.
▲
by
baudehlo
13y ago
That's the point of Google allowing you to email links to your Drive files, not the point of this project. This is to let you get files into your Drive/Dropbox/Skydrive via email. That will still have the limit of whatever email service you
441.
▲
by
baudehlo
13y ago
This is my side project I've been working on for the past month or so. I especially wrote it for Google Drive, since they provide ways to email files already in your Drive, but they don't provide a way for you to send files in.
442.
▲
Show HN: Email files to Google Drive, Skydrive, or Dropbox
(emailitin.com)
46 points
by
baudehlo
13y ago
|
14 comments
443.
▲
by
baudehlo
13y ago
For this I currently use: UPDATE Table SET ... WHERE id=$1 if (rows_updated == 0) { INSERT INTO Table ... WHERE NOT EXISTS (SELECT 1 FROM Table WHERE id=$1) if (rows_inserted == 0) { throw "Conflict!"
444.
▲
by
baudehlo
13y ago
I don't know what your pedigree is in the anti-spam world (personally I wrote large chunks of SpamAssassin, implemented Symantec's Cloud anti-spam engine from scratch, wrote the Haraka SMTP server, and am one of the authors of RFC 6471), bu
445.
▲
by
baudehlo
13y ago
That's impossible. You have two options: 1) Have central control, central management. Facebook has this in their messaging app, and still spend millions of dollars fighting spam on it every year. 2) Have whitelist only email - basically get
446.
▲
by
baudehlo
13y ago
It very much depends on your account visibility. I have the email address helpme@gmail and it gets about 20 spams a day into my inbox (and thousands to my spam folder, so I'm not arguing that it's a bad filter). So it's far from solved. How
447.
▲
by
baudehlo
13y ago
This is already available in some SMTP servers. But it's not a cut and dried situation. It's hard to identify language in very short emails. It's quite possible to get false positives too, when you get mail from someone with an accented nam
448.
▲
by
baudehlo
14y ago
(Opportunity) cost. Right now bitcoin mining is starting to require custom ASICs/FPGAs to be worthwhile (although the increasing price offsets that, obviously), because mining bitcoins becomes harder the more bitcoins there are found, so th
449.
▲
by
baudehlo
14y ago
A bit of shameless self promotion: Haraka is a great mail server for coding up systems for processing incoming email, including parsing out attachments. We use it at Hubdoc for streaming attachments directly from email to S3. http://haraka
450.
▲
by
baudehlo
14y ago
Another reason people haven't considered here is that nginx can display error pages for you when your application server crashes, or is taking too long to serve requests. This is much nicer for the user than a browser error.
More ›