13 ms·
Google Wave Drips With Ambition. A New Communication Platform For A New Web.
- deleted 17y ago[deleted]
- raju 17y agohttp://wave.google.com http://wave.google.com
- deleted 17y ago[deleted]
- zaatar 17y agoIt is an open protocol: http://www.waveprotocol.org/ http://www.waveprotocol.org/
- est 17y agoit's xml based http://www.waveprotocol.org/draft-protocol-spec http://www.waveprotocol.org/draft-protocol-spec looks like XMPP to me I really hate XML
- mcav 17y agoIt's an XMPP extension.
- jonke 17y agoEven if I agree somewhat with your feelings about xml, I think I prefer something like xml over (a sample) of: RFC 1939 POP3 protocol Updated by RFC 2449 RFC 2449 POP3 Extension Mechanism RFC 822 STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGES Obsoleted by RFC 2822 RFC 2822 Internet Message Format RFC 2045 MIME Part One: Format of Internet Message Bodies Updated by RFC 2231 RFC 2046 MIME Part Two: Media Types RFC 2047 MIME Part Three: Message Header Extensions for Non-ASCII Text Updated by RFC 2231 RFC 2183 The Content-Disposition Header Field Updated by RFC 2231 RFC 2231 MIME Parameter Value and Encoded Word Extensions: Character Sets,... RFC 2387 The MIME Multipart/Related Content-type RFC 3462 The MIME Multipart/Report Content-type RFC 2111 Content-ID and Message-ID Uniform Resource Locators RFC 2632 S/MIME Version 3 Certificate Handling RFC 2633 S/MIME Version 3 Message Specification RFC 2821 Simple Mail Transfer Protocol
- mcav 17y agoMIME isn't complicated, nor does it look any more jumbled than XMPP.
- dualogy 17y agoYeah, me too, but writing a bi-directional wrapper for JSON or the even better future thing might be non-trivial -- unless the protocol gets ugly and uglier.
- rcoder 17y agoYeah, it looks a lot like XMPP to me, too: "The Google Wave Federation Protocol is an open extension to XMPP core [RFC3920] protocol..." (From the first paragraph of the draft spec.) Whatever your feelings about XMPP, I challenge you to point to a standardized, interoperable protocol that you think would be a better fit. It may not be ideal, but it's extensible, already supported by a large number of clients and servers, and doesn't require starting from scratch when building interoperable software.
- mattmcknight 17y agoI think there is room for something like AMQP. Most people use libraries to process XMPP anyway, so a binary format wouldn't be a huge change (except, perhaps, in performance).
- vidarh 17y agoAfter starting to read the AMQP spec I wanted to claw my eyes out.
- known 17y agoXML is not suitable for Mobile Platform.
- sketerpot 17y agoWhy not? It's simple enough, and there exist small, fast XML parsers with low memory footprints.
- known 17y agoI'll enumerate the implications and conclusions: 1. XMPP is verbose. 2. XMPP is inefficient for mobile networking. 3. A proprietary binary protocol would be more efficient for mobile devices. 4. The former Android xmppService API will diverge away from XMPP. http://www.deepdarc.com/2008/02/14/mobile-xmpp/ http://www.deepdarc.com/2008/02/14/mobile-xmpp/
- enneff 17y agoThey use XMPP/XML for intra-server communications. It's up to the Wave Server how they serve data to Wave Clients.
- jsonscripter 17y agoThe web is getting really exciting again! I mean, it always has been, but these open protocols, open platforms, and general openness has really got me smiling :) So many possibilities!
- jzachary 17y agoI'm glad somebody is excited. Not to be a downer, but I'm personnaly seeing copy-cat evolution, not revolution. The new toys just aren't going to change the way I work and play.
- ThomPete 17y agoBut for many it will and that will basically create the possibility for google to do ever more finely targeted advertising Which is where they make there money and why they are doing all these products. It makes perfect sense.
- enneff 17y agoIt's in Google's interests, as the king of Internet companies, to be at the forefront of whatever "the future of the Internet" is. I think to imply they crafted Wave specifically with advertising potential in mind is unnecessarily cynical.
- andrewl-hn 17y agoSo, the new thing they did is that they combined Chat and Wiki and then threw some API for mashing up. Made it pretty and Ajaxy. Well, mmm, Ok. I guess many people will like it. I still prefer plain-text emails, though.
- andreyf 17y agoBack in my day, we didn't have any of these fancy real-time-mashups. If you wanted to mash up, you'd show up at the person's front door, pull out a map, and point at things.
- deleted 17y ago[deleted]
- aaronblohowiak 17y agoBack in my day, we used ICQ for collaborative document editing and chat. It worked.
- sketerpot 17y agoSounds kind of clunky, though.
- krav 17y agoWonder what we'll be saying down the road...."in my day, we didn't have these fancy neuron teleporters. If you wanted to mash up, you'd use Twitter or Google Wave." Some young hacker would look up, scratch his head, ask, "What's Google?"
- Scriptor 17y agocombined Chat and Wiki and then threw some API for mashing up. Made it pretty and Ajaxy. Don't fall in the trap of using word choice to make something sound insignificant. Having several people edit the same document in real-time without problems, clearly see when and who updated what, and quickly look at the document's history (honestly, sites like Wikipedia's history feature is just ugly and clunky) can't really be called a wiki. The interface looks really busy from the screenshot and generally doesn't look like products Google usually makes (Chrome, Gmail have pretty clean interfaces, but maybe that's because I'm accustomed to them). If anything, I'm more interested in using the protocol and building a stripped-down version of it.
- mrtron 17y agoThat is the direction AOL always wanted to go with their browser/client. The key difference being the openness of wave.
- trickjarrett 17y agoAnd that it has Google behind it, not AOL. AOL wasn't able to keep up with the innovation and so they fell behind, especially as the walls to the full Internet crashed down and AOL's walled-garden approach became outdated.
- Maro 17y ago1. For this to take off, other providers would have to implement the Wave API/protocol. Other providers like Microsoft, Yahoo, Facebook, etc. Just as today everybody is running SMTP servers. 2. What does open-sourcing mean? Is Google open-sourcing their server-side code? Probably not, since it's tied to the Google architecture anyways. Implementing these APIs/protocols would be a significant expence for the other providers. Also, open-source or not, this would still be a Google-technology (controled by Google), and large corporations don't like to invest in other's technology. 3. Presumably Google would allow Gmail users to upgrade with a click, so they'd have a good amount of seed users. But still, most of my contacts are not @gmail.com, so the experience would be limited. 4. This probably includes email as a special case, eg. your Wave provider is still running SMTP servers and receiving email messages coming to your address (Wave address = email address) and placing them in your Wave inbox, and sending out emails per SMTP if the other side is not Wave enabled. This means painless upgrades in terms of "compatibility" for the user. Correct me if I'm wrong, I've only skimmed the docs!
- blazamos 17y agoAccording to the lead developer, Lars Rasmussen, Google plans to open source the lion's share of their code. In addition, corporations can host their Wave servers. These will be interoperable with any other Wave service provider.
- Scriptor 17y agoIs Google open-sourcing their server-side code? From http://www.waveprotocol.org/ http://www.waveprotocol.org/: our plan is to release an open source, production-quality, reference implementation of the Google Wave client and server So it looks like they will release an example of server code, thought it probably won't be exactly what Google uses. Still, this should allow other people to copy that implementation and make their own servers relatively easily.
- davidalln 17y agoGoogle Code Page: http://code.google.com/apis/wave http://code.google.com/apis/wave
- ttam 17y agohttp://news.ycombinator.com/item?id=350262 http://news.ycombinator.com/item?id=350262
- tybris 17y agoWoah, that could be some pretty disruptive technology.
- deleted 17y ago[deleted]
- joepestro 17y agoWe agree with Google. This is the same idea behind our newly launched startup, http://www.browseology.com http://www.browseology.com If you don't want to wait for Google Wave to see updates from everyone in real time, check it out.
- mitjak 17y agothat's one ugly logo you've got.
- zimbabwe 17y agoGoogle Wave actually looks nothing like your product whatsoever. We already have real-time updates. What we don't have is a system where every sort of update is treated in a single place. That's what Wave is. If you want to advertise Browseology, do it with a post to the front page, and only advertise in other threads if it's relevant to the story. You're borderline spamming right now.
- 0xdefec8 17y agoThis could be revolutionary, however email is the way it is because that's just how we've communicated as a species for eons, all the way from letters to tablets to cave paintings. You think carefully about your message, create something representing it, and share it. It seems like Wave is essentially condensing that process into one step, more like a conversation. I'm not sure everyone will welcome that.
- stcredzero 17y agoPeople tend to do just that on Facebook and Twitter. To really take off, this is crying out for synergy with one of those two.
- dave_au 17y agoIt seems to be acting like a lot of communication tools at once. If there's some way to partition the usage up somehow then it's like a combination of several quality tools in the one place with the option to let the borders blur. It'd be nice to be able to set the communication mode for instance - "this is asynchronous, like an email", and then you don't have to worry about the person you're writing to coming online while you're drafting something you want to word carefully. It sounds like they have something like that but I don't know what the granularity is like. If it can do that you can have your cake and eat it to, and I'd be pretty keen to give it a go. Hell, I'd be happy with email/chat/feed reader/blog interface as separate apps in the same page, just so I could get status info from everything in the same place that I do stuff. Being able to drag and drop things between them all has a fair bit of appeal as well. It's probably a fine line between good integration and a huge shiny mess though.
- CodeMage 17y agoAm I the only one wondering how Google Wave is going to combat spam?
- Raphael 17y agoUsing similar techniques as Gmail and Blogger, I suppose.
- elidourado 17y agoI think I heard someone say whitelisting, but I lost the reference.
- dave_au 17y agoWell, if you're going to try to reinvent email you've got a better chance at making whitelists useful. Even if your inbox (or whatever the wave equivalent is) could divide incoming waves based on whether they were from whitelisted contacts or from unknown contacts, it gets a lot more useful if people whitelist each other by default.
- cschneid 17y agoThis is silly, it doesn't account for the many, many axes of communication. * Push vs. Pull. Does the recipient have to ask to get incoming messages. * Off the cuff vs. Official. How quickly is the communication written, how much thought goes into formal language & proofreading. * Personal vs. Notification (this is a big problem for communication). Regular mail has fallen to this, 99% of mail is automated messages, both wanted and unwanted. Email is going the same direction. Phone never has moved very far that direction. * Filtered vs. Raw. Computer filtered, or human filtered. Spam, autocategorization, etc. And then it adds document problems to it: * Collaborative vs. Sign off. Am I co-writing the document with somebody or is it a write-revise-signoff cycle? * Controlled vs. AdHoc. How formal does the collaboration need to be. Does it make sense for us to both be editing things, or is internal consistency too important to allow concurrent edits? Basically, just saying "screw email, it's a chat! With Widgets!" totally ignores what people use communication services for, and the varying levels of formality, proofreading, speed, style, and automation. A quick rundown of communication protocols that exist: Email: Delayed, Push for the most part, Filtered, lots of notifications IM: Instant, Push, Raw, few notifications Blog: Delayed, Pull, Filtered (RSS reader, you decide what to read), few notifications. Waves: Instant, Push (?), Raw, notifications... maybe? Basically, it fits in the IM category for the most part. Why would this replace my email to the boss containing a page of pros vs. cons on a new technology that we were going to adopt? Would this replace the automated quarterly emails from HR showing me my 401k balance (and does it do the job any better?). Summary: Very technologically cool, but I have no idea how it fits well into the framework of communication types, and adds anything that's not covered adequately with current communication methods. A thought I have had was that twitter flourished because it was a different set of attributes from anything else that existed (along with other things of course).
- aaronblohowiak 17y agoExcellent break-down of the usage patterns of Email and IM. One thing that you hint at is persistence. While we all have the ability to log IMs, email exists as much for archival purposes as it does momentary communication. The simplest way I can put the Email/IM dichotomy is: it is file vs stream.
- deleted 17y ago[deleted]
- zaatar 17y agohttp://wavesandbox.com/ http://wavesandbox.com/ is where people are getting developer accounts from the Google I/O Conference. You may directly navigate to it and add yourself to a waitlist too, if you're not registered at the Google I/O Conference. Direct link: https://services.google.com/fb/forms/wavesignupfordev/ https://services.google.com/fb/forms/wavesignupfordev/
- nickpp 17y agoA solution in search of a problem.
- fauigerzigerk 17y agoI was never a big user of IM or any real time communications (not even phone) so I don't think I would use it much for that. But I do like that they experiment with new forms of collaborative document editing. This has always been a big pain. I have thought about it quite a lot myself. The really difficult thing about collaborative document editing is versioning. The more I think about it the more open questions accumulate. I have my doubts that a tool that wants to be so many things at the same time can be a good enough collaborative document editing tool. For instance, how do I separate the content that is edited from the communcation _about_ that content? Maybe that becomes obvious when we can actually try it.
- Zaak 17y ago> For instance, how do I separate the content that is edited from the communcation _about_ that content? In Wave there is a distinction between editing text and attaching a reply or comment to the text.
- presty 17y agothis is what facebook should've gone for. specially them, due to the social network that they have. the other contender would be linkedin due to the professional atitude they have towards social networking.
- dave_au 17y agoHow would this effect mailing lists?
- dave_au 17y agoGah - too late to edit. I was wondering specifically about how would it effect development mailing lists - with wave plugins to look at patches / browse repositories / review code things could get pretty interesting. Although with non-development mailing lists it could be interesting as long as you could optionally select the group of people to discuss the contents of the list. I'm assuming sometimes it would be better to discuss the contents of the mailing list (or RSS feed) with a select few of your contacts. Discussing the content with all subscribers can be done already (although perhaps not as fluidly) with blog post comments etc...
- omouse 17y agoSo something ambitious is going to be built ontop of complete junk and by forcing the HTTP protocol to handle shit it wasn't meant for. Wonderful. Fucking wonderful. Can we get a time machine and go back to the 80s and start all over again and build up a proper platform before the WWW becomes popular??
- tlrobinson 17y agoNo, it's an extension to XMPP: http://www.waveprotocol.org/draft-protocol-spec http://www.waveprotocol.org/draft-protocol-spec
- omouse 17y agoErm, I was talking about the web-end. I didn't realize there was a separate protocol for it but in any case, XMPP is heavy because it uses XML (which is also somewhat junk).
- jsz0 17y agoI guess I'm not hip or social enough to get it. It's like a glorified e-mail/IM client with avatars and social networking stuff, and a bunch of other things super glued to it? Seems like it might be too ambitious. Maybe there's a good idea in there somewhere but, looking at the tools/sites I use now, I can't imagine why I would want to use this instead. I certainly don't want to waste my time duplicating my efforts on more than one site/service/whatever. Looks like there might be a decent barrier of entry too just figuring out how all these parts work with each other and how you can modify them to work the way you want them to.
- c00p3r 17y agoThere are almost nothing new about this project - the big idea is "lets put all out services together" under new buzzword with the same proven strategy - "we will host and monetize your data" and "we published an APIs, you wll code it out". The same principle is about technology - put it all together XMPP + XML documents (for easy data extraction and indexing) (google docs) + version control (git) + wiki-style editing (wikipedia) + maps, of course + profiles (facebook) + feeds (twitter). And it will probably work, because it is targeted for mobile devices (android) as clients which means instant and short messaging by definition.
- mat3 17y agoSilicon Valley Google Wave Discussion lunch tomorrow (5/31) Come, Bring a Friend and let's discuss Google Wave over lunch. Please use the following link: http://www.socializr.com/event/976099347 http://www.socializr.com/event/976099347 to RSVP. Feel free to forward to anyone who might be interested.