3 ms·
The keywords "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this document are to be inter
by 0cf8612b2e1e 8mo ago
The keywords "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this document are to be interpreted exactly as how much we do not want to review your generated submission.
I know it is in jest, but I really hate that so many documents include “shall”. The interpretation of which has had official legal rulings going both ways.
You MUST use less ambiguous language and default to “MUST” or “SHOULD”
- Muhammad523 8mo agoMany legal documents use "may" to say you must. That's why i hate legalese...
- pixl97 8mo agoHmm, that's annoying, I'd take may as "CAN"
- zdragnar 8mo ago"may only" and "may not", however, are unambiguously hard limits, which makes things even more confusing.
- Throaway8797 8mo ago"may only" means your pleasure is limited only to what options the agreement allows, which is a polite way of saying can not.
- dolebirchwood 8mo agoI don't know what terrible lawyers were hired to draft these "many" documents, but please share some examples.
- LoganDark 8mo agoLegal documents use "may" to allow for something. Usually it only needs to be allowed so that it can happen. So I read terms of service and privacy policies like all "may" is "will". "Your data may (will) be shared with (sold to) one or more of (all of) our data processing partners. You may (will) be asked (demanded) to provide identity verification, which may (will) include (but is not limited to) [everything on your passport]." And so on.
- layman51 8mo agoRight. I think when these appear in some documentation related to computing, they should also mention whether it is using these words in compliance with RFC 2119 or RFC 6919.
- wildzzz 8mo agoMust is a strict requirement, no flexibility. Shall is a recommendation or a duty, you should do it. You must put gas in the car to drive it. You shall get an oil change every 6000 miles.
- 0cf8612b2e1e 8mo agoWell then you MUST reread RFC 2119, because your version of SHALL differs from the spec which says SHALL is equivalent to MUST and a hard requirement. Perfectly making my point. Shall has no business being in a spec when you have unambiguous alternatives.
- msylvest 8mo agoAround 1990 I attended ISO/JTC1 meetings generating standards for data communication. I still recall my surprise over the heated arguments over these words between the UK and the US delegations. (I'm from Denmark). In particular 'shall' and 'should' meant different things in English and American languages. ISO's first standard, ISO 1, states that ISO Standards shall be written in English so we had to do that, US delegation too. Similarly Scott Bradner stated in RFC 2219 how American conventions should be followed for future IETF STDs. So I'm confident that the word 'shall' has a strong meaning in English; whether it has too in American legalese I cannot tell.
- 0cf8612b2e1e 8mo agoNot a lawyer, but I have heard of a few American legal cases where the judge had to decide the meaning of a “shall”, so it does not seem well settled from my vantage.
- layer8 8mo agoOn (possibly weak) counterpoint that I can offer is that in some languages, “must not” is a false friend, easily misinterpreted as “is not required to” (“it is not the case that they must”).