5 ms·
Hardware would catch up. And IPv4 would never go away. If you connect to 1.1.1.1 it would still be good ole IPv4. You would only have in addition the option to
by redox99 10mo ago
Hardware would catch up. And IPv4 would never go away. If you connect to 1.1.1.1 it would still be good ole IPv4. You would only have in addition the option to connect to 1.1.1.1.1.1.1.2 if the entire chain supports it. And if not, it could still be worked around through software with proxies and NAT.
- hypeatei 10mo agoSo... just a less ambitious IPv6 that would still require dual-stack networking setups? The current adoption woes would've happened regardless, unless someone comes up with a genius idea that doesn't require any configuration/code changes.
- krupan 10mo agoI disagree. The current adoption woes are exactly because IPv6 is so different from IPv4. Everyone who tries it out learns the hard way that most of what they know from IPv4 doesn't apply. A less ambitious IPv4 is exactly what we need in order to make any progress
- sgjohnson 10mo agoBut that is a bug in history. IPv6 was standardized BEFORE NAT. “most what they know from IPv6” is just NAT. > A less ambitious IPv4 is exactly what we need in order to make any progress but we’re already making very good progress with IPv6? Global traffic to Google is >50% IPv6 already.
- btilly 10mo agoCurrent statistics are that a bit over 70% of websites are IPv4 only. A bit under 30% allow IPv6. IPv6 only websites are a rounding error. Therefore if I'm on an IPv6 phone, odds are very good that my traffic winds up going over IPv4 internet at some point. We're 30 years into the transition. We are still decades away from it being viable for servers to run IPv6 first. You pretty much have to do IPv4 on a server. IPv6 is an afterthought.
- sgjohnson 10mo ago> We are still decades away from it being viable for servers to run IPv6 first. Just put Cloudflare in front of it. You don’t need to use IPv4 on servers AT ALL. Only on the edge. You can easily run IPv6-only internally. It’s definitely not an afterthought for any new deployments. In fact there’s even a US gov’t mandate to go IPv6-first. It’s the eyeballs that need IPv4. It’s a complete non-issue for servers.
- btilly 10mo agoYou have a point. But you still need DNS to an IPv4 address. And the fact that about 70% of websites are IPv4 only means that if you're setting up a new website, odds are good that you won't do IPv6 in the first pass.
- sgjohnson 10mo agoCloudflare proxy automatically creates A and AAAA records. And you can’t even disable AAAA ones, except in the Enterprise plan. So if you use Cloudflare, your website simply is going to be accessible over both protocols, irrespective of the one you actually choose. Unless you’re on Enterprise and go out of your way to disable it.
- krupan 10mo ago"Just put Cloudflare in front of it" Why do I have to get some third party involved?? Listen, you can be assured that the geek in me wants to master IPv6 and run it on my home network and feel clever because I figured it out, but there's another side of me that wants my networking stuff to just work!
- sgjohnson 10mo agoIf you don’t want to put Cloudflare in front of it, you can dual-stack the edge and run your own NAT46 gateway, while still keeping the internal network v6 only.
- Aloisius 10mo agoPretty sure NAT was standardized before IPv6. NAT is RFC 1631. IPv6 is RFC 1883. Admitted, that was very basic NAT.
- sgjohnson 10mo agoRFC 1631 is a memo, not a standard. Actually, my bad. NAT was NEVER standardized. Not only NAT was never standardized, it’s never even been on standards track. RFC 3022 is also just “Informational” Plus, RFC 1918 doesn’t even mention NAT So yes, NAT is a bug in history that has no right to exist. The people who invented it clearly never stopped to think on whether they should, so here we are 30 years later.
- yrro 10mo agoIf only the inventors of NAT had patented it and then refused to license it!
- Aloisius 10mo agoThat doesn't really mean much. Basic NAT wasn't eligible to be on the standards track as it isn't a protocol. Same reason firewall RFCs are informational or BCP. The protocols involving NAT are what end up on the standards track like FTP extensions for NAT (RFC 2428), STUN (RFC 3489), etc.
- bc569a80a344f9c 10mo agoIt’s not _that_ different. Larger address space, more emphasis on multicast for some basic functions. If you understand those functions in IPv4, learning IPv6 is very straightforward. There’s some footguns once you get to enterprise scale deployments but that’s just as true of IPv4.
- krupan 10mo agoLol! IPv4 uses zero multicast (I know, I know, technically there's multicast, but we all just understand broadcast). The parts of an IPv4 address and their meaning have almost no correlation to the parts of an IPv6 address and their meaning. Those are pretty fundamental differences.
- bc569a80a344f9c 10mo agoIP addresses in both protocols are just a sequence of bits. Combined with a subnet mask (or prefix length, the more modern term for the same concept) they divide into a network portion and a host portion. The former tells you what network the host is on, the latter uniquely identifies the host on that network. This is exactly the same for both protocols. Or what do you mean by “parts of an IPv4 address and their meaning”? That multicast on IPv4 isn’t used as much is irrelevant. It functions the same way in both protocols.
- elcritch 10mo agoIPv4 uses ARP which is just a half baked multicast. IPv6 is much better designed.
- almosthere 10mo agomulticast has been dead for years
- morshu9001 10mo agoThe biggest difference is often overlooked because it's not part of the packet format or anything: IPv4 /32s were not carried over to IPv6. If you owned 1.1.1.1 on ipv4, and you switch to ipv6, you get an entirely different address instead of 1.1.1.1::. Maaybe you get an ipv6-mapped-ipv4 ::ffff:1.1.1.1, but that's temporary and isn't divisible into like 1.1.1.1.2. And then all the defaults about how basically everything works are different. Home router in v6 mode means no DHCP, no NAT, and hopefully yes firewall. In theory you can make it work a lot like v4, but by default it's not.
- throw0101a 10mo ago> I disagree. The current adoption woes are exactly because IPv6 is so different from IPv4. How is IPv6 "so different" than IPv4 when looking at Layer 3 and above? (Certainly ARP vs ND is different.)
- krupan 10mo agoI didn't say it was different 'when looking at layer 3 and above". I said it's different from IPv4. At the IP layer.
- Dylan16807 10mo agoAt the IP layer just being different is 90% of the trouble. Being less ambitious would have some upsides and downsides but not seriously change that.
- throw0101a 10mo ago> I said it's different from IPv4. At the IP layer. In what way? Longer addresses? In what way is it "so different" that people are unable to handle whatever differences you are referring to? We used to have IPv4, NetBEUI, AppleTalk, IPX all in regular use in the past: and that's just on Ethernet (of various flavours), never mind different Layer 2s. Have network folks become so dim over the last few years that they can't handle a different protocol now?
- morshu9001 10mo agoPart of the ipv6 ambition was fixing all the suboptimally allocated ipv4 routes. They considered your idea and decided against it for that reason. But had they done it, we would've already been on v6 for years and had plenty of time to build some cleaner routes too. I think they also wanted to kill NAT and DHCP everywhere, so there's SLAAC by default. But turns out NAT is rather user-friendly in many cases! They even had to bolt on that v6 privacy extension.
- cylemons 10mo agoWhat do you mean by suboptimal allocation?
- _ikke_ 10mo agoThe ipv4 routing table contains many individual /24 subnets that cannot be summarized, causing bloat in the routing tables. With ipv6, that can be simplified with just a couple of /32 or /48 prefixes per AS.
- morshu9001 10mo agoThis, because a bunch of random /24s were sold off to different ISPs, because of address scarcity.
- lmm 10mo ago> The current adoption woes are exactly because IPv6 is so different from IPv4. Everyone who tries it out learns the hard way that most of what they know from IPv4 doesn't apply. In my experience the differences are just an excuse, and however similar you made the protocol to IPv4 the people who wanted an excuse would still manage to find one. Deploying IPv6 is really not hard, you just have to actually try.
- hackthemack 10mo agoSort of. I think people would understand 201.20.188.24.6 And most of what they know about how it works clicks in their mind. It just has an extra octet. I also think hardware would have been upgraded faster.
- sedawkgrep 10mo agoIt would've been even easier and lasted longer to use two bytes of hex at the start. That would've expanded the Internet to 65536x its current space. Something like aaff:a.b.c.d Leaving off the prefix: could just mean strictly IPv4.
- cylemons 10mo agoI think making the extra hex at the end is better, that way its like we are subdividing our existing networks without moving them around
- Macha 10mo agoIn IPv6, this is spelled ::ff00:a.b.c.d It didn’t speed up adoption and people then tried most of the other solutions people are going to suggest for IPv4+. Want the IPv4 address as the network address instead? That’s 2002:a.b.c.d/48 - many ISPs didn’t deploy that either
- deleted 10mo ago[deleted]
- raffraffraff 10mo agoThink of it like phone numbers. For decades people have accepted gradual phone number prefix additions. I remember in rural Ireland my parents got an extra digit in the late 70s, two more in the 90s, and it was conceptually easy. It didn't change how phones work, turn your phone into a party line or introduce letters or special characters into the rotary dial, or allow you to skip consecutive similar digits. For people who deal with ip addresses, the switch from ipv4 to ipv6 means moving from 4 digits (1.2.3.4) to this: 2001:0db8:0000:0000:0008:0800:200c:417a 2001:db8:0:0:8:800:200c:417a 2001:db8::8:800:200c:417a Yes, the ipv6 examples are all the same address. This is horrible. Worse than MAC addresses because it doesn't even follow a standard length and has fancy (read: complex) rules for shortening. Plus switching completely to ipv6 overnight means throwing away all your current knowledge of how to secure your home network. For lazy people, ipv4 NAT "accidentally" provides firewall-like features because none of your home ipv4 addresses are public. People are immediately afraid of ipv6 in the home and now they need to know about firewalls. With ipv4, firewalls were simple enough. "My network starts with 192.168, the Internet doesn't". You need to learn unlearn NAT and port forwarding and realise that with already routable ipv6 addresses you just need a firewall with default deny, and then add rules that "unlock" traffic on specific ports to specific addresses. Of course more complexity gets in the way... devices use "Privacy Extensions" and change their addresses, so making firewall rules work long-term, you should use the device's MAC Address. Christ on a bike. I totally see why people open this bag of crazy shit and say to themselves "maybe next time I buy a new router I'll do this, but right now I have a home with 4 phones, 3 TVs, 2 consoles, security cameras, and some god damn kitchen appliances that want to talk to home connect or something". Personally, I try to avoid fucking with the network as much as possible to avoid the wrath of my wife (her voice "Why are you breaking shit for ideological reasons? What was broken? What new amazing thing can I do after this?").
- redox99 10mo agoThe main thing is keeping current addresses, not having both an ipv4 and ipv6 address. Just like for an apartment you append something like 5B. And for a house you don't need that.
- deleted 10mo ago[deleted]