3 ms·
I had a terrible first impression with Gemini CLI a few months ago when it was released because of the constant 409 errors. With Gemini 3 release I decided to
by tarruda 11mo ago
I had a terrible first impression with Gemini CLI a few months ago when it was released because of the constant 409 errors.
With Gemini 3 release I decided to give it another go, and now the error changed to: "You've reached the daily limit with this model", even though I have an API key with billing set up. It wouldn't let me even try Gemini 3 and even after switching to Gemini 2.5 it would still throw this error after a few messages.
Google might have the best LLMs, but its agentic coding experience leaves a lot to be desired.
- knollimar 11mo agoI had to make a new API key. My old one got stuck with this error; it's on Google's end. New key resolved immediately.
- franze 11mo agoand then loosing half a day setting up billing - with a limited virtual credit card so you have at least some cost control
- knollimar 11mo agoFor me, I had just set up a project and set billing to that. Making a second key and assigning the billing to that was instant; I got to reuse it. I have sympathy for any others who did not get so lucky