4 ms·
The article doesn’t investigate which behaviour is correct, or whether both are justifiable. A very quick, probably flawed investigation suggests the Chromium-
by chrismorgan 4y ago
The article doesn’t investigate which behaviour is correct, or whether both are justifiable.
A very quick, probably flawed investigation suggests the Chromium-family behaviour (meßagefactory → messagefactory) might be correct, and Firefox and Safari (meßagefactory → xn--meagefactory-m9a) incorrect: RFC 3492 (Punycode) defers to RFC 3491 (nameprep), which is a profile of RFC 3454 (stringprep), explicitly using its mapping tables B.1 and B.2, and table B.2 says to map ß to ss (“00DF; 0073 0073; Case map”).
I welcome correction or more detail from anyone more knowledgeable on the matter. It’s fiddly stuff and I haven’t dealt with this stuff very much, so I could very easily have missed a trick.
- belorn 4y agoIf the ß character is a forbidden character then the Chromium-family behaviour is correct. If its a legal character then the Firefox and Safari behaviour is correct. If it is a forbidden character then registrars will not allow you to register xn--meagefactory-m9a.ca, and thus the problem will never exist.
- Svip 4y agoAccording to the German (.de) NIC, Chromium's behaviour appears to be incorrect,[0] though it appears to be the old IDN standard. While for the most part, one can reasonably normalise ß into ss, it can be used to distinguish words, like Buße (penance) and Busse (buses). [0] https://www.denic.de/en/know-how/idn-domains/ https://www.denic.de/en/know-how/idn-domains/
- rippercushions 4y agoThis has not stopped the Swiss for ditching the ß entirely. Then again, the Swiss are also crazy people who say nonante for 90, instead of being French and saying quatre-vingt-dix (4x20+10).
- sofixa 4y ago> Then again, the Swiss are also crazy people who say nonante for 90, instead of being French and saying quatre-vingt-dix (4x20+10). That's not crazy, it's just common sense that for some reason the Académie Française, the authority on the French language, refuses to have.
- mejutoco 4y agoI took it as sarcasm. The way 90/90-something is in french usually causes eye rolling.
- tsimionescu 4y agoWell, if most French people say quatre-vingt-dix-sept for 97, why should the Academy invent a new word of its own to replace it? On the other hand, if people on the street do typically say nonante-sept for that, then I agree that the Academy should recognize the change. As far as I know though, this is not the case at all, and septante/huitante/nonante sound strange to actual French people. Either way, the GP was definitely being sarcastic.
- seszett 4y ago> That's not crazy, it's just common sense that for some reason the Académie Française, the authority on the French language, refuses to have. The Académie Française was in favor of septante, octante and nonante ("octante" is not used anywhere today, by the way, "huitante" is sometimes used in parts of Switzerland but the rest of the French-speaking world uses "quatre-vingts") from the moment it was created, and National Education also recommended these terms until 1945. They just never really became widespread and eventually completely died out in France (Belgium also uses septante and nonante) but the Académie did try to promote them. I'm not sure why one would think the contrary as the Académie has always been quite progressist, probably too much for their suggestions to actually enter usage I guess.
- kzrdude 4y agoThat's a shame, since in this particular example (Buße / Busse) the spelling is a good pronounciation guide and that disappears when the difference is flattened out.
- agwa 4y agoPer the WHATWG URL spec, Chrome is wrong. Chrome is in the process of aligning with the spec: https://bugs.chromium.org/p/chromium/issues/detail?id=694157 https://bugs.chromium.org/p/chromium/issues/detail?id=694157
- zdragnar 4y agoAny idea if the fact that ß is not a legal character per the .ca domain rules impacts how it should be read?
- agwa 4y agoIt's irrelevant that .ca forbids ß. The URL spec is clear, and .de very much allows ß so it's not an academic concern: browsers need to be able to handle it correctly.
- deleted 4y ago[deleted]