6 ms·
US DoD starts using 11.0.0.0/8
- shrineOfLies 11y agoyaay! more IP addresses for all!
- api 11y agoI wish they hadn't. Anything that prolongs IPv4 use is bad.
- endymi0n 11y agoBad news for some ISPs, VPN setups and sysadmins I know who used these addresses as quasi private IPs (extension of 10.x.x.x), as these were all unused before...
- SEJeff 11y agoI've seen a company that uses 7.0.0.0/8 as "lucky number seven" since it is reserved for the DoD as well.
- Thaxll 11y agoWhat kind of company need more than 16M IPs for private adressing?
- wmf 11y agoA company with more than 16M cable modems, for one thing.
- tedunangst 11y agoBut do they all need to be on the same logical network?
- mburns 11y agoThey need to be logically accessible because they are managed devices. NAT doesn't work in this case. Of course, IPv6 is the more correct solution, if you can manage it (no pun intended). See Comcast's presentation about their motivations: http://meetings.ripe.net/ripe-54/presentations/IPv6_management.pdf http://meetings.ripe.net/ripe-54/presentations/IPv6_manageme...
- tedunangst 11y agoThanks, that's interesting, but doesn't explain why "federated net 10 islands" can't work, except to say it can't. New York (time warner) and Chicago (Comcast) are obviously managed separately. Why can't Comcast manage Boston and Chicago as separate networks? Is every single customer nationwide working off the same dhcp/update/management server, etc.?
- wtallis 11y agoBased on the kinds of multi-state outages they suffer from, I'd say they often are all having all modems hitting the same auth/DHCP/DNS servers. Back when I was on BellSouth DSL, every time they had a DNS outage everybody would reboot their modem and that would bring down the DHCP server, but if you used third-party DNS you could remain online while the entire SE US lost DSL for an hour or two.
- api 11y agoIt's not just about number of addresses. It's also about preventing conflicts. Let's say my company uses 10.0.0.0/16. Now let's say I set up a VPN. Half my users will be on local networks that are also 10.0.x.x. Fail. Even worse, let's say my company has two locations and both use 10.0.0.x and now we want to link them on a common network using a VPN or virtual Ethernet bridge. Have fun renumbering one of these two sites, or setting up abominations like internal two-way SNAT/DNAT. The reason IPv6's address space is so huge is to allow relatively stateless assignment of addresses with extremely low probability of conflicts. An IPv6 address is basically a UUID. That's going to make lots of things easier and eliminate the need for a huge number of nasty hacks.
- developer1 11y ago"An IPv6 address is basically a UUID." This is the reason why I can't believe we're not all on IPv6 yet. You would think that the online advertising industry would have done everything in their power to push IPv6, at any cost. 90%+ of people on IPv6 will literally have a unique identifier FOR LIFE on every device they own. Marketers can now pinpoint down not just to an IP address that identifies a single NAT interface, but each individual device. I hope that operating systems and/or routers will provide the option to rotate each IPv6 address on a routine basis. It would also be nice if ISPs would rotate the block that is handed out to each customer, but this is unlikely to happen. Every phone, every tablet, every PC, every thermostat, every door lock, every fridge... uniquely identifiable from the day it is hooked up to a network. :(
- jlgaddis 11y agoRelated: "Why the FBI wants IPv6: It's better [than CGN] for tracking criminals" [0]. [0]: http://gcn.com/articles/2012/06/07/fbi-wants-ipv6-hard-to-track-ipv4-with-nat.aspx?m=2 http://gcn.com/articles/2012/06/07/fbi-wants-ipv6-hard-to-tr...
- mjcl 11y agoGood news, privacy addressing (ex. RFC 4941) exists and is enabled by default on OS X (10.7+) and Windows 7. Privacy addressing rotates the host section of the IP address by default once a day, leaving IPv6 host detection similar to IPv4+NAT. It seems like Linux may be a mixed bag (by distro) w/r/t it being enabled as default. I could definitely see cheap embedded devices based on a current Linux distro not bothering to change defaults to enable it.
- frk 11y agoWho cares ? Almost nobody will need to talk to DoD, so I would still use this subnet as private.
- gnoway 11y agoKind of serves them right, if so. That's the kind of thoughtless violation of standards that should get used as a classroom example of what not to do.
- bg1q6lytelv 11y agoIt's more than a little ironic to be admonishing someone for something so hackish on a website called "hacker news."
- jlgaddis 11y agoIf memory serves, T-Mobile was using 5/8 internally for a long time (because they exhausted 10/8). I imagine they had a lot of fun renumbering out of that once netblocks began to be issued out of it.
- dlitz 11y agoI'm not sure of the timing, but today T-Mobile provides IPv6 and 464XLAT.
- jlgaddis 11y agoYep, this is why I occasionally use reserved addresses other than the widely used RFC 1918 addresses. I use 192.0.2/24 ("TEST-NET") at home (cf. RFC 5737), split up into various subnets. At $work (ISP), we use 100.64/10 (cf. RFC 6598) quite a bit internally (for its intended purpose, *mostly). In other networks, such as companies with many locations that will be connected via VPNs or companies that will have several VPNs to other organizations (where there's less control of the addresses used), I've used 198.18/15 (cf. RFC 2544) to avoid any conflicts. Obviously, this is not what those address ranges are intended to be used for but it's certainly better than both a) using non-reserved address ranges (i.e. public ones that don't belong to you) and b) implementing funky NAT policies because of overlapping addresses.
- devicenull 11y agoReleases is not the proper word here. It should be 'US DoD starts using 11.0.0.0/8'. Nowhere in that thread does it say the subnet is being released back into the generally available pool, just that it's started to be routed.
- dang 11y agoOk, we changed the title to that from "US DoD releases 11.0.0.0/8".
- workworksleep 11y agoThe problem with ipv6 is that it doesn't consider that people are still remembering and typing ip addresses everyday. IPv6 is more effort on the mind and hand. A shorthand version would be better. Ideally if the router ip address is 1, Subnet would be 1.0/24, Client 1.2 Client IP: 1.1 Router: 1 Subnet: 1.0/24 Gateway: 1 I'm too lazy for ipv6. Nothing to celebrate about ipv6 except for a bigger pool and some other minor +.
- SG- 11y agoWhat are you talking about? Users aren't entering IPs for anything other than maybe custom DNS servers. Unless you mean 'advanced' users that set up static machines? Either way if those users want routable IPs going forward and not be stuck behind CGNAT then they'll have to use their brains and learn something new. The truly lazy people like yourself and remain in some sort of segmented Internet I suppose.
- mbrutsch 11y agoThat's just mean.
- mbrutsch 11y agoI found where all the childish redditors went.
- vog 11y agoI agree with you, except for this part: > The truly lazy people like yourself and remain in some sort of segmented Internet I suppose. That last sentence doesn't add anything to the conversation. Your comment wouldn't lose anything by removing that. Also, this one: > they'll have to use their brains and learn something new could have been simply written as follows, again without losing anything: > they'll have to learn something new
- simoncion 11y agoThe last sentence echoes the OP's last sentence, which was as follows: > I'm too lazy for ipv6. Nothing to celebrate about ipv6 except for a bigger pool and some other minor +. Symmetrical construction is nice. :) Additionally, it's pretty appropriate to say: > Either way if [advanced users who are setting up static, globally routable IPs for machines] want routable IPs going forward and not be stuck behind CGNAT then they'll have to use their brains and learn something new. Any sysadmin who is configuring a server that requires a globally routeable IP is expected to use his brain. Moreover, he will be expected to have to use that brain to learn new things from time to time, lest his systems become crusty and unmaintained. There are many things that can go wrong when you configure a machine as an Internet peer. Some amount of savvy and smarts is required.
- jlgaddis 11y agoN.B.: DoD didn't "release" 11/8 in the same way that Interop "released" (i.e., gave back to ARIN) 45/8 several years ago [0]. What they did do was start advertising it into the global BGP routing table (technically, AS23352 did, as the post mentions) -- apparently ~5d6h ago, according to my routers. In addition, AS23352 is sending the ("informational") community "23352:41216" along with this prefix, which means that it was learned by a "customer" peering session at their Chicago, Illinois, POP: Community: 3356:3 3356:22 3356:100 3356:123 3356:575 3356:2042 23352:41216 The other communities attached to this prefix indicate that: a) ServerCentral is a Level 3 customer, and b) Level 3 is receiving the announcement from SC in Chicago. FWIW, I'm receiving the routes via Level 3 peering connections in both Chicago and Cincinnati, Ohio. [0]: http://evilrouters.net/2010/10/20/arin-regains-458-from-interop/ http://evilrouters.net/2010/10/20/arin-regains-458-from-inte...
- edwhitesell 11y agoI remember working with an airline around '01-'02. The CTO was very excited they had migrated all of their network infrastrucutre to new private lines and gotten off of that "terrible 10-dot network". I asked which private network they switched to and he said "We switched to 11-dot, because no one else uses it and it'll be unique for the future growth of our private network." Needless to say, he was not pleased to learn it was not private, or unique and was assigned to the DoD.
- icedchai 11y agoSo this "CTO" had never heard of Whois? I think I first heard of it in 1991.
- edwhitesell 11y agoThere are still lots of people who have "puppy farm" technical certs. This was certainly one of them.
- gnu8 11y agoWhy is the US DoD permitted to own a /8? They are the greatest force against peace and for suffering the world has ever known. Their robots kill civilians daily and they have compromised the security of the Internet for the sole purpose of expanding and maintaining their power. Every ISP has a duty to block traffic to and from 11/8 until such a time as the DoD relinquishes it to the proper authorities for distribution to legitimate users.
- yincrash 11y agoAre you aware that the Internet evolved out of a connection of academic institutions with the DoD's network as the backbone? The DoD was literally the first implementators of TCP/IP as well as where the research was started and funded. Vint Cerf was a DARPA manager.
- dizzyviolet 11y agoYou want a realistic answer? "Finders keepers. We made it." Now, I do agree that it's a massive chunk and it could be better used given up to the rest of the internet, but honestly we should be pushing harder on ipv6 instead. The whole "They are the greatest force against peace and for suffering the world has ever known" part is a matter of opinion and I disagree with that statement.
- termain 11y agoI wonder if this had an impact on the AT&T backhaul that went wonky today.
- jlgaddis 11y agoIt's been advertised since (at least) around 1800 GMT last Thursday so I doubt it's related.