Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
wpollock
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
5 ms
·
61.
▲
by
wpollock
7mo ago
RFCs have four digit numbers. This will likely change within a month or so; RFC 9945 was recently assigned so it won't be long. I wonder what RFC9999 and RFC10000 will be?
62.
▲
by
wpollock
7mo ago
If they're Greek ferrets, apparently they become constipated. :-)
63.
▲
by
wpollock
7mo ago
This discussion reminds me of this bit of security theatre: < https://wpollock.com/images/Security-done-wrong.jpg >
64.
▲
by
wpollock
7mo ago
> RFC 1738 was superseded by RFC 3986 (URIs) ... RFC 3986 has the same wording (appendex C), < https://datatracker.ietf.org/doc/html/rfc3986#appendix-C >.
65.
▲
by
wpollock
8mo ago
It's been a few years, but for Java I used OWASP: < https://owasp.org/www-project-dependency-check/ >, which downloads the NVD (so first run was slow) and scans all dependicies against that. I ran it from mav
66.
▲
by
wpollock
8mo ago
Here's a handy shell script to show only the options from a command's man page: showoptions() { man -s 1 "$*" |col -bx |awk '/^[ ]*-/,/^$/' |less } (Won't work for ever
67.
▲
by
wpollock
8mo ago
An interesting approach, Good luck with it! A nit to pick: find is not a bash command. You can run it for example from a Windows DOS command line as: wsl find ... You can run all Linux commands this way. Also, pretty sure that find'
68.
▲
by
wpollock
8mo ago
The first section in the introduction describes a YAML file. Bait and switch?
69.
▲
by
wpollock
8mo ago
There's always TECO! <Joking>
70.
▲
by
wpollock
9mo ago
> Steel-manning the idea, perhaps they would ship object files (.o/.a) and the apt-get equivalent would link the system? I believe this arrangement was common in the days before dynamic linking. You don't have to redownload eve
71.
▲
by
wpollock
9mo ago
> Ban publication of any research that hasn't been reproduced. Unless it is published, nobody will know about it and thus nobody will try to reproduce it.
72.
▲
by
wpollock
9mo ago
One purpose of QA testing is compliance assurances, including with applicable policies, industry regulations, and laws. While devs are (usually) good at functioal testing, QA (usually) does non-functional testing better. I have not known a
73.
▲
by
wpollock
9mo ago
Some points: LLM oral exams can provide assessment in a student's native language. This can be very important in some scenarios! Unlimited attempts won't work in the presented model. No matter how many cases you have, all will e
74.
▲
by
wpollock
9mo ago
If it's not a breaking change, why would a unit test fail as a result, whether or not using mocks/fakes for the code not under test? Unit tests should test the contract of a unit of code. Testing implementation details is better
75.
▲
by
wpollock
9mo ago
> Someone changes code to check if the ResultSet is empty before further processing and a large number of your mock based tests break as the original test author will only have mocked enough of the class to support the current implementa
76.
▲
by
wpollock
10mo ago
> We actually disable NTP entirely (run it once per day or at boot) to avoid clocks jumping while recording data. This doesn't seem right to me. NTP with default settings should be monotonic. So no jumps. If you disable it Linux en
77.
▲
by
wpollock
10mo ago
YouTube video ids are just integers in a base-64 encoding, modified to be URL safe.
78.
▲
by
wpollock
10mo ago
> I live on a small farm with his wife, son, and two dogs. Should you trust translations into English by someone who writes sentences like this? <joking> In the movie When Harry Met Sally, Billy Crystal said hieroglyphics were act
79.
▲
by
wpollock
10mo ago
> The cgroup2 file system is now mounted with the "memory_hugetlb_accounting" mount option, supported since kernel 6.6. > Required minimum versions of following components are planned to be raised in v260: * Linux kerne
80.
▲
by
wpollock
10mo ago
If you didn't already know, what do you think a tool called "emacs" does?
81.
▲
by
wpollock
10mo ago
> The better peer reviews are also not this 'thorough' and no one expects reviewers to read or even check references. Checking references can be useful when you are not familiar with the topic (but must review the paper anyway)
82.
▲
by
wpollock
10mo ago
The obvious solution is for half of the hardware to run on dark energy, counteracting the heat generated by the other half. Venture capitalists, use my gofundme site to give me the millions needed to research this, thanks.
83.
▲
by
wpollock
11mo ago
> I can put the cuff on my arm and sit at my desk for 20 minutes to be nicely rested and calm, and then take 5 different measurements with a few minutes between each one. ... Doesn't it take more than a few minutes for one's c
84.
▲
by
wpollock
11mo ago
This post, along with the tutorial links it and the comments contain, provide good insights on the topic of caches, coherence, and related topics. I would like to add a link that I feel is also very good, maybe better: < https:/&#x
85.
▲
by
wpollock
1y ago
In the 1980s, PT and ET were common. I was working at Bell Labs then, and one of my jobs was to change the time zone (back then it was two words) on the testing machines, as needed. This is stuck in my memory since to change the timezone,
86.
▲
by
wpollock
1y ago
Wasn't there a HN post a few weeks ago, describing how your phone's location can be tracked without anything installed and without leaving any trace on your phone? I think it was an exploit of CSS7 protocol used by networks?
87.
▲
by
wpollock
1y ago
That password should include symbols too! Without symbols, each character is one of 62 values (sticking to ASCII letters and digits). Including symbols makes it much harder to guess passwords of a given length. Even better would be Unico
88.
▲
by
wpollock
1y ago
I appreciate this post! I was hoping you would add an inline CSS style sheet to take care of the broken defaults. I only remember one off the top of my head, the rule for monospace font size. You need something like: code, pre, tt,
89.
▲
by
wpollock
1y ago
> It is interesting that no software engineering or computer science course I’ve seen has ever spent any time on CI/CD. It's hard to fit everything student needs to know in the curriculum. Someone else posted here they had 10 p
90.
▲
by
wpollock
1y ago
> There are hurdles still to overcome. In particular, we still have to figure out a way to make the top of our diamond coatings atomically flat. Not sure I understand this. Is this a requirement for real-world use? What happens if the
More ›