Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
spc476
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
16 ms
·
151.
▲
by
spc476
3y ago
This [1] might be a better example. C isn't Pascal, you can't just define a type of integer with a fixed range, so here, I check to ensure that the code above has done its job. I don't want an if statement here for this, fo
152.
▲
by
spc476
3y ago
Then the assert() triggers and you fix the assert() (or the bug). What's the issue here?
153.
▲
by
spc476
3y ago
a) They can have names (internally). At my previous job, our test suite required every test be a single file, and yet it still output TAP (you specified which tests you wanted via filenames). b) No, you don't have to know prior how ma
154.
▲
by
spc476
3y ago
And then you hit: warning: ISO C forbids assignment between function pointer and `void *' Which, while true, is allowed (and in fact, required by) POSIX. Of course, not passing "-pedantic" will suppress that warni
155.
▲
by
spc476
3y ago
As i_don_t_know stated, if the CPU has the ability to single step an instruction, you use that. Otherwise: * Restore the original instruction byte. * Find the next instruction, and set a temporary software breakpoint there. * Resume the o
156.
▲
by
spc476
3y ago
Gemini can, in fact, serve up images, audio and even video. The specification disallows inline display of such types, but it can serve them fine.
157.
▲
by
spc476
3y ago
Scanning through this, it's actually a tutorial for GNU make.
158.
▲
by
spc476
3y ago
I used LD_PRELOAD to test system call failure code paths in a program ( https://boston.conman.org/2022/12/21.1 ) that would otherwise be difficult to test.
159.
▲
by
spc476
3y ago
Yes, there are moderated groups. I even know of a moderated group without a moderator (alt.hackers) which is the point.
160.
▲
by
spc476
3y ago
No, it was more like before they pushed "Enterprise Agile with a side of scrum", the team I was on, for 10 years, produced code on time, with very few bugs and only two regressions to production (caught during deployment). Afterw
161.
▲
by
spc476
3y ago
First, there was major miscommunication on the part of the new management [1] and who I thought was my manager wasn't [2]. Second, I was raising the alarm that the "agile and scrum" methods weren't working, and got it r
162.
▲
by
spc476
3y ago
At my previous job, the "daily stand up" never lasted less than 30min, and often times went to 2 hours. Also, I didn't just have one "daily stand up" but two! One with multiple teams, and one with just our team be
163.
▲
by
spc476
3y ago
I have a Gmail account [1] and I regularly get email for other people who share my name (at least three others). I find it amazing they think that's their email address (or other people think that they'll reach the right person b
164.
▲
by
spc476
3y ago
How about using non-break spaces in filenames? It worked when I last tried it ( https://boston.conman.org/2018/02/28.2 ).
165.
▲
by
spc476
3y ago
You don't want vendor lock-in. The vendor, however, has different incentives---why would they want to prevent lock-in to their service?
166.
▲
by
spc476
3y ago
I've got two such stories. Around 2000, I was working at a huge web hosting company (third shift, monitoring the network). Suddenly the power went out. Turns out, the building management (separate company) decided to run a UPS test
167.
▲
by
spc476
3y ago
C programs start out in the "C" locale, so just using fgetwc() won't work out of the box (or won't do what you expect it to do). You'll need to call setlocale("") to get the expected behavior.
168.
▲
by
spc476
3y ago
I'm not fond of traveling either. For me to go somewhere, there has to be a friend (or friends) or family there to visit. I dislike going somewhere just to go, and have found that typically, it's not worth the experience. I tra
169.
▲
by
spc476
3y ago
What type of programming do you do? Because in my experience, programming is as much an art as it is a science (or mathematics). In my previous job, I had to classify phone numbers as either 1) valid NANP [1], 2) invalid NANP [2], or inte
170.
▲
by
spc476
3y ago
https://boston.conman.org/ Twenty-four years of back-log, and it's a mix of technical and personal content.
171.
▲
by
spc476
3y ago
Some CPUs don't have a MUL or (like some 32-bit RISC architectures) DIV instruction, and on these, the C compile has to fall back to a function call.
172.
▲
by
spc476
3y ago
Mainly, it was Dave not bothering to clarify how to include HTML in the RSS feed, instead saying, "the spec is the spec and it's not changing!"
173.
▲
by
spc476
3y ago
Where would configuration options via environment variables fit in? I can see between 0 and 1, or 1 and 2, but can't quite decide which is better.
174.
▲
by
spc476
3y ago
I have a gopher server written in Lua [1] that uses coroutines to handle each connection. This bit of code is executed as the main menu page [2] is being displayed (with comments) -- ------------------- -- Load in some modules.
175.
▲
by
spc476
3y ago
I tried right clicking to open the link in a new tab, and found I couldn't. What is it with these bespoke browsers written in JavaScript?
176.
▲
by
spc476
3y ago
Markdown does have a MIME type, as defined in RFC-7763 and RFC-7764. Markdown was rejected from Gemini for being too complex. "text/gemini" can be parsed line by line, which is why it was defined the way it was.
177.
▲
by
spc476
3y ago
There was some work on using RFC-3987 but it went nowhere as there was contention about how to handle international domain names---do you convert to puny code or not? Seriously, that's where it got hung up on.
178.
▲
by
spc476
3y ago
Back in 1999, an acquaintance of mine became a paper millionaire of a dot-com and bought a 2.3M home in Boca Raton, Fl, and put in a further half million renovating it. As he was driving me and a few friends through the neighborhood, he in
179.
▲
by
spc476
3y ago
It might be a better idea to serve up a 418 ("I'm a tea pot") with a line line text file saying "I'm not an HTTP server". That solved a problem I had with bots making HTTP requests to my gopher server [1]. Se
180.
▲
by
spc476
3y ago
I have three volumes on my bookshelf. Volume 0 is a reference for the X protocol itself. Volume 1 covers programming with Xlib, and Volume 2 is the Xlib reference. The linked to book appears to be how to administrate an X server. And I k
More ›