Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
spc476
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
43 ms
·
481.
▲
by
spc476
5y ago
"Don't worry about people stealing your ideas. If your ideas are any good, you'll have to ram them down people's throats." -- Howard Aiken
482.
▲
Notes on Designing a Search Engine
(search.marginalia.nu)
1 points
by
spc476
5y ago
|
0 comments
483.
▲
by
spc476
5y ago
I recently came across the search engine Marginalia [1], which ranks web sites based on the ratio of text to HTML tags (more text, better score), with a very heavy penalization for JavaScript. [1] https://search.marginalia.nu
484.
▲
by
spc476
5y ago
Not all CPUs have carry and overflow flags. For example, MIPS, or SPARC, or the new RISC-V.
485.
▲
by
spc476
5y ago
I agree, automatic testing would be nice. Unfortunately, I'm the one at work having to do write the said automatic testing of a component that makes parallel DNS requests [1] in an event driven server [2] and need to test that we cove
486.
▲
by
spc476
5y ago
One could add a side channel to tell it to fail certain calls. I'm doing a similar thing at work---I have a mock DB that runs with a side channel for the testing framework to tell the mock DB what to pass and what to fail (I should sa
487.
▲
by
spc476
5y ago
The most unusual tech support call I received was from a deaf person. I worked at an ISP that supported UUCP (at the time, mid-90s). The deaf person was familiar with UUCP and wanted to set up an acccount. I really feel sorry for the tra
488.
▲
by
spc476
5y ago
Here's a bit of detail about an internal attack I was involved with: http://boston.conman.org/2004/09/19.1 It wasn't a disgruntled employee---it was an employee who was hired by another party to get hire
489.
▲
by
spc476
5y ago
The Gopher+ protocol doesn't seem to be that popular in practice, and the only evolution of the gopher protocol since the mid-90s is the introduction of a few new selector types not found in RFC-1436 (like 'i' and 'h
490.
▲
by
spc476
5y ago
I don't know how common it is, but I do it. I encode foreign terms as <span lang="de" title="above everything">über alles</span>. How the client deals with that is up to the client, but most of th
491.
▲
by
spc476
5y ago
I am aware of at least one blind person on the Gemini mailing list, talking about their experiences with it (mostly about Gemini's native text format).
492.
▲
by
spc476
5y ago
Name an ISP that will allow non-filtered TCP port 25 traffic for a non-business account to go through.
493.
▲
by
spc476
5y ago
My blogging engine [1] also supports submission via email (and has for twenty years). I have a unique email address for it and it has never been spammed (or received anything from anybody except for me). The only check my software does
494.
▲
by
spc476
5y ago
subdomain.example.com can be hosted on completely different infrastructure, but what about DNS? Unless you have two different DNS providers for the main domain, you still have single point of failure for the entire domain (and all subdoma
495.
▲
by
spc476
5y ago
I work in Ft. Lauderdale, Florida. The home office is in Seattle, Washington. I've made it clear at work that I'm not about to fly to the Seattle office [1] (not that I've ever needed to, but others in my office have). On
496.
▲
by
spc476
5y ago
Prior to 9/11, going between the US and Canada just meant answering a few questions, no passport needed, at least between Detroit and Winsor.
497.
▲
by
spc476
5y ago
Six years ago, a friend of mine vacationed in a private rail car with his family. I got to ride in it for three hours [1], and just that trip spoiled me for all further travel. My friend never did say what it cost him. I suspect it was th
498.
▲
by
spc476
6y ago
That won't work because '[' is an alias for test.
499.
▲
by
spc476
6y ago
I don't know about POSIX, but C doesn't mandate an implementation. The C Standard says about getenv(): Quote: The getenv function searches an environment list, provided by the host environment, for a string that matches the strin
500.
▲
by
spc476
6y ago
If you go by RFC-7763 and RFC-7764, then CommonMark would be served as: text/markdown;variant=CommonMark
501.
▲
by
spc476
6y ago
libtls. I wish it this API was more popular than it is, as it makes using TLS way easier. https://github.com/spc476/libtls-examples/blob/master/get1.c
502.
▲
by
spc476
6y ago
Dr. Seuss Enterprices probably own the copyright to the books they don't want to distribute. Amazon Inc probably does not own the copyright to the books they don't want to distribute.
503.
▲
by
spc476
6y ago
Having an R-rating didn't mean a lack of toys. "Alien" came out in 1979 to an R-rating. Yet a friend at the time (we were both 10) received a 12" (30cm) xenomorph action figure for Christmas.
504.
▲
by
spc476
6y ago
There are no C standard functions, aside from malloc(), calloc() and realloc(), that have to allocate memory to work. I think that's intentional on the part of the C standard library.
505.
▲
by
spc476
6y ago
Yes it was. On early Unix systems, each entry in a directory was bascially: struct dir { char name[14]; int inode; }; Adding a NUL byte might waste a full byte that could otherwise be used---remember, back whe
506.
▲
by
spc476
6y ago
While this happened to me in 2004, I can still see it working even today: http://boston.conman.org/2004/09/19.1
507.
▲
by
spc476
6y ago
Or take advantage of the ABI of the runtime, and use assembly. [1] Yeah, not portable. But using setjmp()/longjmp() has issues as well (way too easy to mess it up because it doesn't do what you think it's doing). [1] https
508.
▲
by
spc476
6y ago
Kilroy was never here. He just thought he was.
509.
▲
by
spc476
6y ago
Yes, Apple can take the offending app down upon receiving a DMCA takedown. Then the offender can, depending on how profitable the app is, send in a counter-DMCA notice, forcing Apple to put the app back up in two weeks and now Apple is off
510.
▲
by
spc476
6y ago
Except for alt.hackers. It was a moderated newsgroup but there was no moderator. How do you post? That was the point. It was a fun group.
More ›