Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
deweerdt
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
14 ms
·
91.
▲
by
deweerdt
13y ago
@bnegreve can't reply to your post, but i was mistaken. externally visible symbols are also initialized to 0
92.
▲
by
deweerdt
13y ago
No, they're not. In fact, if the program used 'static main;' instead, it wouldn't even compile because the 'main' symbol wouldn't be visible by the linker.
93.
▲
by
deweerdt
13y ago
> Also, global variables in C are initialized to zero implicitly, so this is equivalent: EDIT: this is wrong, see below. That's wrong. 'static' variables are initialized to zero. Non-static variables are un-initialized, so they have a
94.
▲
by
deweerdt
13y ago
> - Sound is excellent, good automatic echo cancellation and reasonable noise reduction. I agree with most of the points you've raised. In low bandwidth settings my personal experience is that skype does better sound-wise though.
95.
▲
by
deweerdt
13y ago
He, it's been a while. Thanks for the correction.
96.
▲
by
deweerdt
13y ago
I thought this was more due to the 'embedded' culture. After all, under VxWorks, isn't all memory addressable by all processes?
97.
▲
by
deweerdt
13y ago
It doesn't seem to make sense in this context. One hypothesis is that it could have been done out of habit to write safer code: whether char is signed or unsigned is left to the implementation, whereas int is guaranteed to be signed.
98.
▲
by
deweerdt
13y ago
I'm going to go ahead and be pedantic: that format is not part of the SMTP spec. It's part of the Internet Message Format RFC (5322 in its latest incarnation), which describes what's in the body of the email. The SMTP spec (RFC 5321) which
99.
▲
by
deweerdt
13y ago
I used an early version of http://www.sleeptracker.com/ and it worked well.
100.
▲
by
deweerdt
13y ago
It takes about 2 hours to boot to bash prompt ("init=/bin/bash" kernel command line). Then 4 more hours to boot up the entire Ubuntu ("exec init" and then login). Starting X takes a lot longer.
101.
▲
by
deweerdt
13y ago
> but that doesn't mean this isn't a very emotional and trying time for many, I think you're right, it is a very emotional time for many. I think he's trying to put that in a more rational perspective so that we, collectively, don't for
102.
▲
by
deweerdt
14y ago
Well, it's affordable in Detroit right now.
103.
▲
Corporate tie binds US to a slow internet
(ft.com)
1 points
by
deweerdt
14y ago
|
0 comments
104.
▲
by
deweerdt
14y ago
Citing Feldman's turkish carpet study as a reference is interesting: Christopher Alexander (architectural design patterns, at the origin of software design patterns) also studied turkish carpets in 'Foreshadowing of 21st Century Art: The Co
105.
▲
by
deweerdt
14y ago
It's not the language itself. It's its implementation. Embedding a Lua interpreter in a C program is straightforward. See the 'Python' and 'Java' slides in the OP: it's all about integration.
106.
▲
by
deweerdt
14y ago
You can: - 'git checkout -b branch_name' to create a branch - 'git checkout branch_name' to switch branches - 'git commit' to add dummy commits (no need to git add stuff) Edit: formatting
107.
▲
SPEC2000 comparison of LLVM-3.2 and coming GCC4.8
(vmakarov.fedorapeople.org)
1 points
by
deweerdt
14y ago
|
0 comments
108.
▲
Dehydration, heatstroke and cardiac risk
(sportsscientists.com)
1 points
by
deweerdt
14y ago
|
0 comments
109.
▲
Laser power beaming keeps drone fully charged
(optics.org)
1 points
by
deweerdt
14y ago
|
0 comments
110.
▲
by
deweerdt
14y ago
There is, strace does just that. perf trace is still evolving though and appears promising. See, for example, scripting support: http://lwn.net/Articles/371448/
111.
▲
by
deweerdt
14y ago
According to http://seclists.org/fulldisclosure/2012/Nov/94 it would inject an iframe in each http response.
112.
▲
by
deweerdt
14y ago
It depends on what you mean by works. CMake actually works for me.
113.
▲
by
deweerdt
14y ago
Yes, absolutely. When people want to validate an email address, it's more likely they're referring to the SMTP envelope address: http://tools.ietf.org/html/rfc5321#section-4.1.2 RFC 822 (RFC 5322 in its more recent incarnation) refers to
114.
▲
by
deweerdt
14y ago
There's a typo: the code you pointed to says Highcarts.com, it should read Highc_h_arts.com
115.
▲
by
deweerdt
14y ago
I second the use pomodoro technique, it's a great way to keep track of time. Shameless plug: i wrote an online pomodoro timer http://yay.im/pomodoro
116.
▲
by
deweerdt
14y ago
> I hope and expect that the Bank would not consider putting the image of a living person on a note. I dunno, I'd make an exception for John Cleese.
117.
▲
by
deweerdt
14y ago
could you expand?
118.
▲
by
deweerdt
14y ago
> that you have to assume someone else at the Atlantic wrote this headline In the newspaper industry, that's common practice. It takes a different skill set to sum up an article in a small amount of words and to write said article.
119.
▲
by
deweerdt
14y ago
Not to mention googling them.
120.
▲
by
deweerdt
16y ago
In addition to that, clicking on the "+1" button yields a "Use my information to personalize content and ads across the web." checkbox. Not sexy.
More ›