Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
dc396
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
9 ms
·
121.
▲
by
dc396
1y ago
Sure. As it is a fundamental flaw in the DNS protocol itself, it is not unique to dnsmasq (it applies to any resolver).
122.
▲
by
dc396
1y ago
No. The special characters thing is a red herring. All resolvers must handle a lack of response via timeout (particularly since DNS mostly uses UDP). The correct mitigation is turning on DNSSEC. This sort of attack, known since 1993, is why
123.
▲
by
dc396
1y ago
A nit: we've known about the flaw since 1993 (see https://www.cerias.purdue.edu/assets/pdf/bibtex_archive/94-0... )
124.
▲
by
dc396
1y ago
No. RFC 2181, section 11 states explicitly: "Those [length] restrictions aside, any binary string whatever can be used as the label of any resource record. Dnsmasq should (MUST in RFC 2119 language) forward requests -- it would be a b
125.
▲
by
dc396
1y ago
This is why DNSSEC was created.
126.
▲
by
dc396
1y ago
No. They aren't "invalid requests". You can put literally anything in a domain name (see RFC 2181, section 11) and the upstream should respond. I'm curious what resolvers are dropping these requests. The correct behavio
127.
▲
by
dc396
1y ago
Your hostnames with emojis are violating RFC 1123 as modified by RFC 2181. But as I said, it is a convention and, of course, RFCs aren't laws of physics, you can violate them at the risk of potential interoperability failure (e.g., may
128.
▲
by
dc396
1y ago
I'm confused. There are no "special characters" in domain names -- they're length-tagged 8-bit clean. Hostnames (as opposed to domain names) are limited by convention to a subset of ASCII, but that shouldn't impac
129.
▲
by
dc396
1y ago
I suspect the phishing scammers will appreciate the help in identifying good phishing lures. Snark aside, it continues to boggle my mind that the people who click on a lure get punished. A failed test indicates a need for system improvement
130.
▲
by
dc396
1y ago
According to one of our new AI overlords: Separation of Powers and Congressional Authority • Trump repeatedly challenged or ignored the constitutional boundaries between the executive branch and Congress. This includes refusing to comply wi
131.
▲
by
dc396
1y ago
Unfortunately, the RFK Jr and his ilk already believe they know the truth, so any evidence to the contrary is purely noise that is filtered out.
132.
▲
by
dc396
1y ago
Yep. She didn't reappear in history until the 1950s when Babbage's papers were reviewed with the increased development of computing as a field of study (and really took off in the 80s when US DOD sponsored the development of the A
133.
▲
by
dc396
1y ago
> GOP is in theory all about small government, libertarian ideas, states rights. You're describing what the GOP (arguably) used to be about. I doubt anyone who pays attention seriously believes that's what today's GOP stan
134.
▲
by
dc396
1y ago
Evidence is obviously a conspiracy by the Biden administration. (/s sigh).
135.
▲
by
dc396
1y ago
Yeah, so maybe interesting, but you might want to provide a bit more context/background on who is driving this, business model, and explain when you say "infrastructure", you're talking about content, not actual layer-&l
136.
▲
by
dc396
1y ago
The truly sad part is that regardless of the validity of the study, its methodology, or the results, the impact it will have in the political sphere or with the public will be negligible. It's maddening.
137.
▲
by
dc396
1y ago
And https://www.redox-os.org ?
138.
▲
by
dc396
1y ago
A few options: - testing in preparation for a future attack - proof of capability ("Nice network you have there. It'd be a shame if something happened to it") - misfire ('What happens when I push this button that says &q
139.
▲
by
dc396
1y ago
Those are a selection I've subscribed to (and pay for Patreon/TWIT membership for Data over Dogma and Security Now respectively to support the creators). If you like Data over Dogma, another in the academic study of early Christi
140.
▲
by
dc396
1y ago
See the short story "With Folded Hands" by Jack Williamson (written in 1947).
141.
▲
by
dc396
1y ago
It fascinates (and depresses) me that there are people who actually believe Musk's “nobody in the car” and “unsupervised” promises in the last earnings call.
142.
▲
by
dc396
1y ago
Data over Dogma (academic study of earlychristianity/bible/religion) Left, Right & Center (politics) Rational Security (national security/foreign affairs) Security Now (computer security) This Week In Virology (virus/
143.
▲
by
dc396
1y ago
The folks involved in the project have been pretty open about their project plans/timelines, speaking about it in webinars and various conferences, and have largely followed what they claimed. Making it available to the public undoubte
144.
▲
by
dc396
1y ago
> But I am concerned a "OS for the EU" Initiative will end up like all EU IT projects, that being smothered by red tape and (political) comitee stewardship. "All"? DNS4EU ( https://www.joindns4.eu ) seems to
145.
▲
by
dc396
1y ago
Or... people are just the mechanism by which smartphones reproduce. </s>
146.
▲
by
dc396
1y ago
Might want to look at who provides most of the funds for Mozilla.
147.
▲
by
dc396
1y ago
And the Internet treats censorship like damage and routes around it. Until it doesn't. I have faith in humanity's ability to remain as selfish as they have always been -- technology won't change that.
148.
▲
by
dc396
1y ago
Err, no. At least not according to Cloudflare: https://blog.cloudflare.com/why-we-terminated-daily-stormer/ TL;DR: "The tipping point for us making this decision [to discontinue service] was that the team behind D
149.
▲
by
dc396
1y ago
An interesting assertion. A quick Google search didn't turn up anything definitive for me. Do you have references?
150.
▲
by
dc396
1y ago
Who cares? The statement "MAGA's assault on science is an act of grievous self harm" is, in my view, equivalent to stating "water is wet." The fact that it is published by or even an opinion of the owners of a publi
More ›