Y
HN Search
Hacker News Search
new
|
comments
|
top
|
jobs
ay
searching PlanetScale…
1.
▲
2.
▲
3.
▲
4.
▲
5.
▲
6.
▲
7 ms
·
61.
▲
by
ay
1y ago
“You had an MTU problem. You enable jumbo frames. Now you have two MTU problems” Unless you control the entire set of possible paths (can be many!) and set all the MTUs to match well, this (while maybe on surface helping with the problem, d
62.
▲
by
ay
1y ago
Of course on the carrier boxes the fragmentation is done also not inline, so its behavior will depend on the aggressiveness of the CoPP configuration, and will be subject to the same pitfalls as the ICMP packet too big generation. Thanks
63.
▲
by
ay
1y ago
> "everyone is expecting 1280" This works great until there is an app that is expecting 1280 and there is an operator that gives you 1280, and you have to run this app over an encrypted GENÈVE tunnel that attempts to add half
64.
▲
by
ay
1y ago
I had looked at Zed, but it’s a GUI, and I would rather stay inside a terminal for a variety of reasons. Helix I didn’t try though… It might be a bit closer to what I am after, so I will definitely give it a try even if as a source of ins
65.
▲
by
ay
1y ago
From the pragmatic standpoint: manually hard coding a safe minimum is the only approach which consistently works. PMTUD somehow missed that packet networks ditching the OOB mechanisms of circuit switched networks was a good thing. By addin
66.
▲
by
ay
1y ago
With IPv4, clearing the DF bit in all egress packets and hacking on top of QUIC could give just enough of a wiggle room to make it possible to explore this between a pair of cooperating hosts even in today’s Internet. Anti-DDoS middle boxes
67.
▲
by
ay
1y ago
Thanks, hopefully it will be of any use and not too buggy ! (It was a classic “worked on my machine for my needs”, but I would be very suspicious of the autogenerated code being 100% bug-free). I looked shortly at LSP but never had experien
68.
▲
by
ay
1y ago
Thanks for the feedback ! The evidently misguided assumption was that whoever uses it will need to tweak it anyhow, so might as well read it through. As I wrote - it’s very close to throwaway code. Anyway, I decide to experiment with Claud
69.
▲
by
ay
1y ago
I have just went through this with a project of mine, though unfortunately the code wasn’t autogenerated, so I needed to do a lot of mind-numbingly boring search-and-replace commands. I have cobbled together a little utility that allowed to
70.
▲
by
ay
1y ago
Your positive attitude and the talent is inspiring. Thank you very much!
71.
▲
by
ay
1y ago
I clicked through to the project at https://github.com/FractalFir/rustc_codegen_clr - from a quick glance at it, with 1.8k stars and 17 contributors, it deserves a better treatment than a passive—aggressive dismissal
72.
▲
by
ay
2y ago
Just noticing this exact phenomenon as a beginner learning wing foil: over two days, one day I can barely stand up, and only on one side, feeling very wobbly. The very next day, I am easily standing up on both sides, and can pump (which inv
73.
▲
by
ay
2y ago
To second this and expand on the reasons behind: The way the NATs (network address translators) are sharing the scarce public IPv4 addresses is by multiplexing on the transport level fields (ports in case of TCP/UDP and IDs or inner pa
74.
▲
by
ay
2y ago
Typing “2”, “+”, “3” on an iPhone in Safari gets it to display “23+”, which doesn’t appear correct to me ? Looks cute otherwise.
75.
▲
by
ay
2y ago
Haskell dilettante here… The “IO a” vs “a” reminded me of async vs sync - where the first one returns a promise/future to be awaited on, rather than a result. Is there any parallel there, or is it an entirely wrong perception I got ?
76.
▲
by
ay
2y ago
True :) the nice thing with 108 is that it is supposed to be “seamless” - that is, you will see (by the absence of leases) that “it’s finally time” to remove it. And the legacy old devices will still continue to work till then.
77.
▲
by
ay
2y ago
If you have NAT64, DNS64 and use “IPv6-mostly” option 108 on DHCP, then CLAT will be activated on supporting devices automatically - and then you can turn the dhcpv4 off when you see no leases on it :-) By now there is a fair amount of mat
78.
▲
by
ay
2y ago
The better you can describe the interdependencies between the components, the more chances the selective approaches have. However, often if you knew about a given dependency, you might have avoided bugs in the first place! A simple scenario
79.
▲
by
ay
2y ago
it wasn’t luck, it was very deliberately engineered for. The article does lack a good bit of context about the Netflix infra: https://netflixtechblog.com/the-netflix-simian-army-16e57fba... https://github.com
80.
▲
by
ay
2y ago
Actually it is a little bit more subtle. The intent with Happy Eyeballs was to focus on user experience: give IPv6 a slight initial advantage to hopefully only make only an IPv6 connection for the dual stack and not waste the network reso
81.
▲
by
ay
2y ago
The challenge with any tool that uses the probe traffic other than the traffic of interest is that the results may be specific to the probe traffic and completely different from the one you care about. In theory, iOAM ( https://da
82.
▲
by
ay
2y ago
With DWDM one can increase the useful bandwidth of the cable; some useful links from a recent presentation that I had handy: https://m.youtube.com/watch?v=VKpAIx0zG-U https://nlnog.net/static/nlnogday20
83.
▲
by
ay
2y ago
His idea, if I understand it right, is to do two transitions instead of one: 1) first, add 12 bytes to each address 2) then build out the IPv6 on this free space. The problem is that (1) can not happen everywhere at once. So your “128bit
84.
▲
by
ay
2y ago
Falling back to IPv4 if IPv6 does not succeed is literally the day 1 behavior of IPv6 transition. Except for TCP it may take a few minutes which is clearly unacceptable. So we wrote RFC6555. It still doesn’t help in the case of PMTUD blac
85.
▲
by
ay
2y ago
Yes. https://github.com/rofl0r/chaos-pp
86.
▲
by
ay
2y ago
Yeah. “Why don’t you just…” :-) djb has a lot of brilliant ideas and excellent implementations of them. But this is neither. On the flip side this article could serve as a great example of a Nobel disease :-)
87.
▲
by
ay
2y ago
Quote from the doc: “ Answer: We go through every place that 4-byte IPv4 addresses appear, and allow 16-byte IPv6 addresses in the same place.” - this text is pretty much the definition of “IPv6 transition”.
88.
▲
by
ay
2y ago
“ As mentioned in Google VPC network valid IPv4 ranges, Class E addresses (240.0.0.0/4) are reserved for future use, as noted in RFC 5735 and RFC 1112 — however, that doesn’t mean you can’t use them today in certain circumstances.” Wow
89.
▲
by
ay
2y ago
A tangentially related networking trivia that probably won’t be useful to anyone here: NetBEUI (the original MS networking, running directly over Ethernet rather than TCP/IP), was using LLC-2 Ethernet frames, and as such it was a great
90.
▲
by
ay
2y ago
Any pointers to RTFM / llama repo for that ? I could not find anything on a cursory look. Thanks in advance !
More ›