5 ms·
Microsoft server crash leaves 800 planes with no contact with ATC
... The servers are timed to shut down after 49.7 days of use in order to prevent a data overload, a union official told the LA Times. To avoid this automatic shutdown, technicians are required to restart the system manually every 30 days.
- username 17y agoDesmond?
- param 17y agoSounds more like a fault of the application than the OS. M$ in the title seems to be there for page views
- russss 17y agoIt's worth noting that this article is from September 2004. 49.7 days is 2^32 milliseconds. Although this used to cause issues with Win98, they claimed to be using 2000, so it was probably an application-related bug rather than anything Microsoft should be blamed for.
- ryanpetrich 17y agoGetTickCount() wraparound bug.
- devicenull 17y agoSo this is essentially human error because someone failed to restart the server. The same thing would have happened if it was running Linux, Unix, etc.
- fatdog789 17y agoThis is both inaccurate and out-dated.