4 ms·
The RFC process seems to work quite well for defining and clearly documenting standards. But I simply cannot understand how this RFC adds any value. All it does
by mcherm 13y ago
The RFC process seems to work quite well for defining and clearly documenting standards. But I simply cannot understand how this RFC adds any value. All it does is to define some words!
By way of comparison, RCF 2119 has been a very successful and useful RFC. A naive reader might think that it simply defines some words, providing definitions for "SHOULD", "MUST", "MAY", "REQUIRED", and "OPTIONAL". But that is not the case... it does not provide _definitions_ for these words. Instead, it provides a standard describing how they are to be used in writing standards documents. Whether we like it or not, is a fact of the English language that "The document should end in a newline." can mean that it is optional but desirable for a document to end in a newline, or it can mean that a document ending in anything else would be invalid. But the sentence "The document SHOULD end in a newline.", appearing in a standards document that references RFC 2119 is not ambiguous -- 2119 specifies a particular protocol for use of these words.
As far as I can tell, RFC 3092 has none of those redeeming qualities. It does not specify what a metasyntactic variable is, how to use one correctly, and which metasyntactic variable list to use... instead it just provides the definition and origins of "foo", "bar", and "foobar". A dictionary would be a better source for that, not an RFC.
- Malus 13y agoLook at the date of the RFC; I am pretty sure that this document was not meant to be taken seriously whatsoever.
- mcherm 13y agoAh... I somehow missed that bit. Thanks.
- skriticos2 13y agoIt's a popular April's fool from the IETF. They do this sometime. Pigeon carrier protocol is another well known one: http://www.ietf.org/rfc/rfc1149.txt http://www.ietf.org/rfc/rfc1149.txt Here is a long list with other humor RFC's from IETF: http://www.cs.hmc.edu/~awooster/joke_rfcs.html http://www.cs.hmc.edu/~awooster/joke_rfcs.html
- waps 13y agohttp://en.wikipedia.org/wiki/April_Fools'_Day_Request_for_Comments#List_of_April_1st_RFCs http://en.wikipedia.org/wiki/April_Fools'_Day_Request_for_Co... This years' batch : A new X.509 certificate type : "NSA", RFC 7169 https://tools.ietf.org/html/rfc7169 https://tools.ietf.org/html/rfc7169 A new extention to RFC 2324 to allow the brewing of tea, RFC 7168. https://tools.ietf.org/html/rfc7168 https://tools.ietf.org/html/rfc7168 (RFC 2324 is HTCPCP HyperText Coffee Pot Control Protocol) Just because they're april fools RFCs doesn't mean they don't work : http://www.blug.linux.no/rfc1149 http://www.blug.linux.no/rfc1149
- mcherm 13y agoOops. I somehow overlooked the date.