3 ms·
Ask HN: Why no URIs for email?
Hey HN,
I've been curious about this question for sometime, but why wasn't email standardized to have a URI for each individual message?
I've read RFC5322, but there doesn't seem to be any discussion devoted to why there isn't any URI specified for an email message.
Granted, each individual mail server (and indeed, even email clients) could assign their resource address differently, but wouldn't it be nice if a email message is addressable by an address?
Or am I missing something entirely
- _delirium 13y agoIt does, unless I misunderstand what you mean. The original URL RFC, RFC 1738 (http://tools.ietf.org/html/rfc1738 http://tools.ietf.org/html/rfc1738), envisioned three URI schemes relating to email. The mid: scheme would refer to messages by message-id, the cid: scheme to parts of a MIME-encoded message by content-id, and the mailserver: scheme would refer to resources on a mailserver. The mid/cid schemes were further specified in RFC 2111 (http://tools.ietf.org/html/rfc2111 http://tools.ietf.org/html/rfc2111) a 1997 proposed standard, updated in 1998 (http://tools.ietf.org/html/rfc2392 http://tools.ietf.org/html/rfc2392). These do what you want, I think: mid:message-id is a URI referring to an individual message. The mailserver: scheme was never further defined, and was formally moved to the history books in 2011 (http://tools.ietf.org/html/rfc6196 http://tools.ietf.org/html/rfc6196).
- chewxy 13y agoOh thank you. Didn't know it was in another different standard.