4 ms·
>Using a single, unreplicated database instance in production for anything serious is bizarre It is incredibly common. Go check out a thousand businesses runn
by Sssnake 13y ago
>Using a single, unreplicated database instance in production for anything serious is bizarre
It is incredibly common. Go check out a thousand businesses running mysql, you'll be able to count the ones using replication on your fingers.
>Failed hardware is hardly unheard of.
You don't need to use mysql replication to deal with that. Even the crappiest low end SAN storage devices do it vastly better than mysql does, without any of the bugs and problems mysql replication has.
- jeltz 13y agoI have heard stories of entire SANs failing so I would not advice trusting your SAN too much. For example there was a huge outage at a Swedish host caused by a failed SAN, all data was lost so people had to use daily backups to restore. Replication can be done off-site so you at most lose a couple of seconds worth of data. I do not know anything about MySQL's replciation but my trust in PostgreSQL's is very high.
- Sssnake 13y ago>I have heard stories of entire SANs failing Which is why it is being replicated, like I said.