4 ms·
That is absolutely ridiculous. Less than 1% of 1% of mysql users are using replication. Suggesting it is a "total non-starter" for most production uses is cra
by Sssnake 13y ago
That is absolutely ridiculous. Less than 1% of 1% of mysql users are using replication. Suggesting it is a "total non-starter" for most production uses is crazy.
- oceanplexian 13y agoYou're kidding right? I'd wager that a huge number of MySQL users are using replication. Running a single database in a production environment is totally unacceptable and a major business continuity problem.
- Sssnake 13y ago>Running a single database in a production environment is totally unacceptable and a major business continuity problem. You don't need to use mysql's broken replication to get HA. Hell, I've seen more people (wisely) using DRBD for that than using mysql's replication. But even entry level storage devices do replication.
- whatusername 13y agoHow many wordpress installs use replication?
- kisstheblade 13y ago" Running a single database in a production environment is totally unacceptable" What hyperbole. I've been running mysql in production for over 15 years over almost a hundred projects, almost always on a single server without any replication. Never had any issues with it. Shame I can't down vote yet.
- ceejayoz 13y ago> Less than 1% of 1% of mysql users are using replication. If you count all the crappy shared hosts, XAMPP local installs, and hobbyists setting up their own little VPSes, perhaps. Using a single, unreplicated database instance in production for anything serious is bizarre. Failed hardware is hardly unheard of.
- Sssnake 13y ago>Using a single, unreplicated database instance in production for anything serious is bizarre It is incredibly common. Go check out a thousand businesses running mysql, you'll be able to count the ones using replication on your fingers. >Failed hardware is hardly unheard of. You don't need to use mysql replication to deal with that. Even the crappiest low end SAN storage devices do it vastly better than mysql does, without any of the bugs and problems mysql replication has.
- jeltz 13y agoI have heard stories of entire SANs failing so I would not advice trusting your SAN too much. For example there was a huge outage at a Swedish host caused by a failed SAN, all data was lost so people had to use daily backups to restore. Replication can be done off-site so you at most lose a couple of seconds worth of data. I do not know anything about MySQL's replciation but my trust in PostgreSQL's is very high.
- Sssnake 13y ago>I have heard stories of entire SANs failing Which is why it is being replicated, like I said.