4 ms·
Ask HN: Why did the BEEP protocol never get much traction?
I've always wondered why the BEEP protocol never did get much traction. It seems like a very well thought out specification (RFC-3080 / RFC-3081)
- mindcrime 13y agoI always wondered that as well. It seems like an interesting standard. More info here, FWIW: http://en.wikipedia.org/wiki/BEEP http://en.wikipedia.org/wiki/BEEP http://beepcore.org/ http://beepcore.org/
- mohaps 13y agoyeah. I always find RFC 3117 (basically design notes) very interesting to read : http://tools.ietf.org/html/rfc3117 http://tools.ietf.org/html/rfc3117
- erkose 13y agoBecause JSON won.
- mohaps 13y agofair point, erkose. But why didn't the JSON-ified successor to BEEP come about? As someone who has spent the last 15 years basically trying to plumb bandwidth aware/adaptive chatty AND bulk-data-transfer applications, I always look at the RFC's and see a ton of good ideas. No fan of XML... but that's a personal bias.