4 ms·
Ruby 1.8.7 EOL in 90 days
- cleverjake 14y agoI wonder if that means OS X's ruby will be upgraded finally.
- andymoe 14y agoMaybe, but I can guarantee it won't get done until 10.9 comes out. EDIT: If you really want to see the level of effort for them to do this go buy OS X Server from the app store and dig around for ruby files ;-)
- cleverjake 14y agoI wouldn't be surprised if thats the case, but its not like 1.8.x being sunset was a surprise to anyone - 1.9 is 4+ years old. Hopefully someone has been working on it up to now
- stock_toaster 14y agoIf not, maybe they can skip straight to 2.0.
- gurkendoktor 14y ago> 1.9 is 4+ years old 1.9.1->1.9.2 had breaking changes (most obviously require_relative) and 1.9.2 had performance issues in requiring files. I haven't run into any issues with Ruby 1.9.3, but it's only 1.5 years old, and even 1.9.3 was not 100% backwards compatible. I understand that this all seems like eternity if you are actively developing a Ruby app, but for everything that is in maintenance mode, 1.8.7 has been a very sane choice until now. I had certainly planned to use it another couple years if possible. :/
- wuest 14y agoOrder of installation on new macs: Quicksilver. Brew. Tmux. JewelryBox. Lazy package maintainers have created the perfect atmosphere for a project like rvm to be an essential part of life.
- mceachen 14y agoHere's some relevant articles, given that we all need to get onto 1.9.3 ASAP: Sam Ruby's "What to expect in 1.9.x" slideshow: http://slideshow.rubyforge.org/ruby19.html#1 http://slideshow.rubyforge.org/ruby19.html#1 Airbnb's migration story: http://nerds.airbnb.com/upgrading-from-ree-187-to-ruby-193 http://nerds.airbnb.com/upgrading-from-ree-187-to-ruby-193 Another migration story: http://www.darkridge.com/~jpr5/2012/10/03/ruby-1.8.7-1.9.3-migration/ http://www.darkridge.com/~jpr5/2012/10/03/ruby-1.8.7-1.9.3-m...
- zdw 14y agoI'm sure it will go quickly into the night, just like Python 2.7 and Perl 5.14.
- elithrar 14y agoI don't believe Python 2.7 is deprecated.
- TylerE 14y agowhoosh
- elithrar 14y agoHardly. I made the comment because it does not represent the same situation. Ruby 1.8.7 will no longer receive security patches, which is a big issue and is likely to motivate any half-decent organization to migrate. Python 2.7 and Perl 5.14 will continue to see use because both receive security patches, are still maintained, and in the Python case you also have to worry about (well, less so now) whether the libraries you need have moved to 3.x as well. I'm aware that the GP was trying to be witty, but it doesn't really stick.
- SoftwareMaven 14y agoPython 2.7 wasn't supposed to exist. Python 2.6 was supposed to be EOL for the 2.x series, including being the "help upgrade your code" release, but for many reasons, the line wasn't ready to die. The original poster is implying there will be a Ruby 1.8.8 to support the many who can't/won't upgrade to 1.9.
- Argorak 14y agoThere won't be a 1.8.8, it was already discussed and shot down. 1.8.7 is already a transitional release. Also, given the adoption of 1.9 in the Ruby world, there is also no point.
- 14y ago
- nodata 14y agoUnless you run RHEL.
- Argorak 14y agoThats where the "Enterprise" comes from.
- nodata 14y agoThanks for explaining my comment to me (?)
- yxhuvud 14y agoThere are now packages available[] for 1.9 even for users of RHEL. The real issue there is that the packaging of gems are remade from scratch, so any gems anyone has been forced to package themselves will have to be repackaged. [] Well, I don't know if they have been released in a final form yet but at least there are early versions available.
- epynonymous 14y agothank god! hopefully mac os x will update the included ruby from 1.8.7