3 ms·
> In the early years after 2000, I have witnessed a great number of computer crashes caused by power failures. Don't enable write cache without a power backup,
by Fnoord 2mo ago
> In the early years after 2000, I have witnessed a great number of computer crashes caused by power failures.
Don't enable write cache without a power backup, or on an unstable machine.
> Therefore OpenBSD should be used with an UPS (or on a laptop).
NVMe with PLP is suffice.
The same helps me on my NAS as well, with ZFS and Linux. No need for OpenBSD.
Soft updates was very cool when I first used it, like 25 years ago. Linux didn't have Ext3FS yet, or just about got it. ZFS also worked very early on FreeBSD, but nowadays the standard is OpenZFS.
There's a couple of cool things coming from OpenBSD camp, most notably OpenSSH and PF.