4 ms·
Wow, yuck. (The "Why do we even have that lever?!" line comes to mind.) ...even so, without a disk failure, that probably wasn't the cause of this event.
by scottlamb 6mo ago
Wow, yuck. (The "Why do we even have that lever?!" line comes to mind.)
...even so, without a disk failure, that probably wasn't the cause of this event.
- zootboy 6mo agoThe DUP profile is meant for use with a single disk. The RAID* profiles are meant for use with multiple disks. Both are necessary to cover the full gamut of BTRFS use cases, but it would probably be good if mkfs.btrfs spat out a big warning if you use DUP on a multi-disk filesystem, as this is /usually/ a mistake.
- scottlamb 6mo ago[dead]
- singron 6mo agoZFS has similar configurations possible (e.g. copies). You can end up in this state with btrfs if you start with a single device (defaults to data=single,metadata=dup), and then add additional devices without changing the data/metadata profiles. Or you can choose this config explicitly. I really wish the btrfs-progs had a --this-config-is-bad-but-continue-anyway flag since there are so many bad configurations possible (raid5/raid6, raid0/single/dup). The rescue tools are also bad and are about as likely to make the problem worse as fix it.