5 ms·
This broke our builds since we rely on several public Docker images, and by default, Docker uses docker.io. Thankfully, AWS provides a docker.io mirror for tho
by ic4l 1y ago
This broke our builds since we rely on several public Docker images, and by default, Docker uses docker.io.
Thankfully, AWS provides a docker.io mirror for those who can't wait:
FROM public.ecr.aws/docker/library/{image_name}
In the error logs, the issue was mostly related to the authentication endpoint:
▪ https://auth.docker.io https://auth.docker.io → "No server is available to handle this request"
After switching to the AWS mirror, everything built successfully without any issues.
- anon7000 1y agoI manage a large build system and pulling from ECR has been flaking all day
- firloop 1y agoI wasn't able to get this working, but I was able to use Google's mirror[0] just fine. Just had to change FROM {image_name} to FROM mirror.gcr.io/{image_name} Hope this helps! [0]: https://cloud.google.com/artifact-registry/docs/pull-cached-dockerhub-images https://cloud.google.com/artifact-registry/docs/pull-cached-...
- ic4l 1y agoWe tried this initially FROM mirror.gcr.io/{image_name} We received failed to resolve source metadata for mirror.gcr.io/ So it looks like these services may not be true mirrors, and just functioning as a library proxy with a cache. If you're image is not cached on one of these then you may be SOL.
- da768 1y agoDuring the last Docker Hub outage we found Google mirrors lost all image tags after a while. Image digest references would probably work
- CamouflagedKiwi 1y agoMild irony that Docker is down because of the AWS outage, but the AWS mirror repos are still running...
- geostyx 1y agopublic.ecr.aws was failing for me earlier with 5XX errors due to the AWS outage: https://news.ycombinator.com/item?id=45640754 https://news.ycombinator.com/item?id=45640754
- kerblang 1y agoAlso, docker.io is rate-limited, so if your organization experiences enough growth you will start seeing build failures on a regular basis. Also, quay.io - another image hoster, from red hat - has been read-only all day today. If you're going to have docker/container image dependencies it's best to establish a solid hosting solution instead of riding whatever bus shows up
- suriya-ganesh 1y agobased on the solution, it seems like it is quite straightforward to switchover
- pploug 1y agoRate limits are primarily applied to unauthenticated users, open source projects and business accounts have none/much higher tresholds