4 ms·
Once, after we had an application go live, we started getting reports after a few hours that new users were unable to log in. It turns out, somewhere in the au
by prein 1y ago
Once, after we had an application go live, we started getting reports after a few hours that new users were unable to log in.
It turns out, somewhere in the auth path, a dev had used `==` to verify a user's ID, which worked for Longs under (I believe) 128, so any users with an ID bigger than that were unable to log in due to the comparison failing.