3 ms·
Sharing undocumented gotcha: nginx default config (/etc/nginx/nginx.conf) now has `server_tokens off` set with a comment that it's "common practice" (agreed). T
by styanax 1y ago
Sharing undocumented gotcha: nginx default config (/etc/nginx/nginx.conf) now has `server_tokens off` set with a comment that it's "common practice" (agreed). This is not in upstream's git version of the file[1], I therefore presume it's a Debian maintainer change.
The operational upgrade failure is if you have any existing drop-in config that sets `server_tokens off` already a hard fail Nginx error about duplicated keywords will occur, causing the apt process to exit with failure code(s) during the standard upgrade process.
[1] https://github.com/nginx/nginx/blob/master/conf/nginx.conf https://github.com/nginx/nginx/blob/master/conf/nginx.conf
- JdeBP 1y agoTip: Debian provides browsable source repositories so it is usually easy to find out whether something is a local Debian change. * https://packages.debian.org/source/sid/nginx https://packages.debian.org/source/sid/nginx * https://salsa.debian.org/nginx-team/nginx/-/commit/3e7838a6b214e430dadaecf931c1f1531c636581 https://salsa.debian.org/nginx-team/nginx/-/commit/3e7838a6b... * https://salsa.debian.org/nginx-team/nginx/-/merge_requests/80 https://salsa.debian.org/nginx-team/nginx/-/merge_requests/8...