4 ms·
"Email is Easy" email address quiz
- tyilo 1y agoLast week I created a script for finding which TLD's have MX records. Result: cf: ["mail.intnet.cf."] gp: ["ns1.nic.gp."] gt: ["aspmx.l.google.com.", "alt1.aspmx.l.google.com.", "alt2.aspmx.l.google.com.", "aspmx2.googlemail.com.", "aspmx4.googlemail.com.", "aspmx5.googlemail.com."] hr: ["alpha.carnet.hr."] km: ["mail1.comorestelecom.km."] mq: ["mx1-mq.mediaserv.net."] mr: ["mail.nic.mr."] tt: ["ASPMX.L.GOOGLE.COM.", "ALT1.ASPMX.L.GOOGLE.COM."] ua: ["mr.kolo.net."] ws: ["mail.worldsite.ws."] موريتانيا: ["mail.nic.mr."] عرب: ["your-dns-needs-immediate-attention.عرب."] PS: Only http://uz/ seems to have a "working" HTTP server, returning the 500 status code.
- vthriller 1y agoI'm not sure if I'd count examples with spaces and comments towards valid emails, because one could argue these are not part of the address, they're email header syntax details. Like, sure, FWS from RFC can be used somewhere in the address, but it can also be in any other header. Also, CFWS and whatnot are going to get stripped anyway by the time you'd have to deal with SMTP (see Forward-path in RFC 5321, which doesn't allow `(nonsense in parentheses)`), so I don't think they should be considered part of the valid address anyway.
- docsaintly 1y agoI think using example.com is a bit of a trick question. It is known as an example domain which is invalid for all purposes, except of course for serving as an example. :) https://www.iana.org/help/example-domains https://www.iana.org/help/example-domains
- wredcoll 1y agoI've actually been wondering for a while if example.com is a valid example email address.
- mdaniel 1y agoWell, "valid," yes, but "deliverable" thankfully, no $ dig MX example.com. ;; ANSWER SECTION: example.com. 3600 IN MX 0 . Almost certainly the same for its .org .net and .example friends. There were some other TLDs that were designed for use in documentation, but I don't have the RFC in front of me right now to cite them
- SoftTalker 1y agoSome of the other examples which are "technically valid but obsolete" I would consider safe to call invalid for practical purposes.
- samwho 1y agoYeah, I almost put a disclaimer at the end saying that while these examples are valid according to the spec, that has no bearing on whether they’re usable in practice. Email is the Wild West.
- olddustytrail 1y agoExactly. Not valid because it can't be routed.
- TMWNN 1y agoYes. If I'd known that other questions would also use example.com, I would have answered the first question correctly.
- paulnpace 1y agoAn explanation of the use of example.com would have informed users that addresses should be evaluated as such, otherwise, AFAICT, all of the examples provided are invalid.
- sour-taste 1y agoLove it. Minor but question 8 should maybe be 'trailing' instead of 'tailing'?
- samwho 1y agoGood eyes! Code is at https://github.com/samwho/e-mail.wtf https://github.com/samwho/e-mail.wtf if you’d like to open a PR
- rpgraham84 1y agowould be nice if what valid means was clearly defined before the test. what the rfc's regex allows is probably the least useful way to think about email validation.
- mdaniel 1y agoI see some of the sibling comments seem to imply that "valid" means that it's deliverable at that moment in time, which would make producing a quiz like this some nonsense because then they'd have to actually register xn--tp8h as a domain, and create an MX record for it
- samwho 1y agoI do have a short sentence on the homepage saying I used https://github.com/jackbearheart/email-addresses https://github.com/jackbearheart/email-addresses as the validator for the examples. It could be more clearly defined, though.
- xigoi 1y agoI scored 17/21 on https://e-mail.wtf https://e-mail.wtf and all I got was this lousy text to share on social media.
- mdaniel 1y agoAs far as I know, that emoji question due to the same reason IDN is allowed in URLs, and they even went as far as their own RFC for it https://datatracker.ietf.org/doc/html/rfc6530 https://datatracker.ietf.org/doc/html/rfc6530 (very similar to the 6532 cited repeatedly, but more important(?) because every system in between the sender and recipient needs to know about hops, whereas the recipient is the terminal node's problem The LHS is, as far as I know, because the LHS of _all_ email addresses is "if it's deliverable", modulo the rest of the call-outs from the rest of the quiz
- stavros 1y agoThis is fun, but it feels suspiciously close to my old presentation about the exact same thing: https://www.youtube.com/watch?v=xxX81WmXjPg https://www.youtube.com/watch?v=xxX81WmXjPg Maybe it's just a coincidence, but a shoutout would have been nice if not.
- Dilettante_ 1y agoSame guy made https://jsdate.wtf https://jsdate.wtf, also posted to HN, and also containing material from someone else's talk I'm pretty sure. Edit: I was wrong!
- samwho 1y agoSimilar to this I got my examples for jsdate.wtf through reading the v8 date parsing code and experimentation. Wasn’t aware there was a talk with similar examples for JS dates, would be interested to see it.
- Dilettante_ 1y agoMy bad, I was thinking about a much older talk[1], maybe something about the theme activated the same neurons. Sorry for making an accusation like that for what turns out was no reason. [1]https://www.destroyallsoftware.com/talks/wat https://www.destroyallsoftware.com/talks/wat
- samwho 1y agoIt’s okay <3 it doesn’t surprise me that both of these topics have been covered before, and both are fairly small input spaces so there’s bound to be similarities or overlap. I do love Gary’s “wat” talk, it was certainly part of the inspiration to make these.
- samwho 1y agoCoincidence. I hadn’t seen this. I got my examples mostly from looking through https://github.com/jackbearheart/email-addresses/blob/master/test/tests.json https://github.com/jackbearheart/email-addresses/blob/master... and reading the EBNF in RFC 5322. Will watch your video!
- zvr 1y agoThere should have been questions without "@" as well...
- samwho 1y agoAre there valid emails without an @? I’m very vaguely aware of bang paths but didn’t want to include them because they’re a bit too esoteric.
- fanf2 1y agoCanonically postmaster is valid without a domain in SMTP. Traditionally mail messages can be composed to local users without writing domains in their addressses, and the message submission service will add domains where necessary.
- zvr 1y agoWell, of course, in a multi-user system you can send an email to "user". Typically used for system processes to email "root" back in the day, or "postmaster" or other system accounts, as well. Bang paths host!user or even host1!host2!user were used in the past, and I think they are still supported by most MTAs. They are definitely valid syntax for email addresses. I mean, if you're talking about quotes and parentheses, ...
- tmdetect 1y agoFunny. I definitely knew there were some unique characteristics, but this took it to a new level.
- fanf2 1y agoSome notes: * Single-label domains are problematic in several ways. Traditionally they are used as local abbreviations on the assumption that TLDs can’t be mail domains – tho that’s false, because several ccTLDs have had MX records at one time or another. Still, mail software can vary in whether it might treat single-label domains as abbreviations or TLDs or both. And there’s the historical anomaly that RFC 2821’s syntax disallows single-label domains; this was a drafting mistake not an intentional change. * Spaces around local parts are valid or not depending on which spec you are following, so question 7 is badly framed. You need to be clear whether you are parsing a mail address as in the SMTP envelope, or an address and display name as in a message header. * Similarly, comments are not valid in SMTP so the questions about comments are also poorly framed. * And the syntax of domain literals / address literals is specified by SMTP, so question 16 and 18 are based on not reading enough of the RFCs.
- jayski 1y ago15/21. I was expecting a question about simple%example1.com@example2.com. which I remember was a useful trick when I worked as a sendmail admin in the early 2000s.