2 ms·
Offsite replica is only applicable if the cause is a failure of the primary. What if I’m restoring a backup because someone accidentally dropped the wrong table
by Arbortheus 1y ago
Offsite replica is only applicable if the cause is a failure of the primary. What if I’m restoring a backup because someone accidentally dropped the wrong table?
- ants_everywhere 1y agoI would hope dropping a table on a production database is something that is code reviewed
- benreesman 1y agonah, on a long enough timeline everything will go wrong. blaming the person who managed to drop the table finally is dumb: if you can't fix literally everything that could happen to it, it's not done.
- anonymars 1y agoIsn't the entirety of disaster recovery about situations that aren't supposed to happen? High availability is different from disaster recovery
- nijave 1y agoYou can PITR on a replica which would be much faster than restoring a full backup of a large DB