5 ms·
Unfortunately that just gets me a helpful "Journaling could not be enabled". I guess something got messed up when I was writing to the volume from Linux.
by udp 14y ago
Unfortunately that just gets me a helpful "Journaling could not be enabled". I guess something got messed up when I was writing to the volume from Linux.
- lloeki 14y agoWhat about: $ diskutil enableJournal /dev/diskXsY ML's diskutil(8) says: enableJournal device Enable journaling on an HFS+ volume. This works whether or not the volume is currently mounted (the volume is temporarily mounted if necessary). Ownership of the affected disk is required. disableJournal [force] device Disable journaling on an HFS+ volume. This normally works whether or not the volume is currently mounted (the volume is temporarily mounted if necessary). If the force option is speci- fied, then journaling is disabled directly on disk; in this case, the volume must not be mounted. Ownership of the affected disk is required. moveJournal external | internal [journalDevice] device external will create a 512MB Apple_Journal partition out of journalDevice and an HFS+ partition will be created out of the remaining space if available; journalDevice must be a partition, not a whole-disk. The journal for device will then be moved externally onto the newly created Apple_Journal partition. internal will move the journal for device back locally. I don't know if it can work on the mounted root filesystem so you may want to try that from the recovery partition.