9 ms·
Pretty RFC
- ionforce 14y agoAwesome. But I've never heard of the "is now diamonds" meme...
- snprbob86 14y agoIt is a reference to Old Spice's "The Man Your Man Could Smell Like" ads: http://www.youtube.com/watch?v=owGykVbfgUE http://www.youtube.com/watch?v=owGykVbfgUE
- deleted 14y ago[deleted]
- kijeda 14y agoIt would have more utility if in the search box you could type the RFC/BCP/STD number, e.g. "1591" or "STD 3". Unfortunately every RFC I tried, except for the provided examples, returned "Could not prettify this RFC".
- sasha-dv 14y agoSame here. DISCLAIMER: This reply contains a slightly modified implementation of RFC 1097.
- mislav 14y agoAdded that you can write the RFC number in the search box. Will do so for BCP/STD in the future. Yes, "could not prettify this RFC" is a problem I'm having right now because most sources aren't available. I'm working on obtaining those sources.
- zwp 14y agoCute, I like the way ASCII art is preserved. Small bug: RFCs < 1000 that are not prettifiable have a extraneous zero in the datatracker.ietf.org link. Eg: http://pretty-rfc.herokuapp.com/RFC123 http://pretty-rfc.herokuapp.com/RFC123 redirects to: http://pretty-rfc.herokuapp.com/RFC0123 http://pretty-rfc.herokuapp.com/RFC0123 (left padding is probably a mistake here; some day we will have >9999 RFCs) links to: http://datatracker.ietf.org/doc/rfc0123/ http://datatracker.ietf.org/doc/rfc0123/ (404) should link to: http://datatracker.ietf.org/doc/rfc123/ http://datatracker.ietf.org/doc/rfc123/ ps. XML format for RFCs that this leans on: http://pretty-rfc.herokuapp.com/RFC2629 http://pretty-rfc.herokuapp.com/RFC2629
- mislav 14y agoThanks for the report. Fixed.
- ndespres 14y agoWhen I search for "1483", my only result is 2684, which supersedes it. But when I try to view it, I'm told "The source XML for this RFC isn't available, therefore it can't be reformatted." Did the IETF shut you down? I don't think the original documents on the IETF datatracker site are that bad- it seems pretty clean and easy to read already.
- saurik 14y agoThe RFC for IMAP returns the same error regarding the XML source. I had assumed that it was parsing the text files, but apparently it only supports parsing the subset of RFCs that have XML available. :(
- rjurney 14y agoThis is great. Small complaint: searching for RFC2822 comes up with nothing. 2822 gets what I want. Plz to fix :)
- augusto_hp 14y agoVery close layout to http://documentup.com/ http://documentup.com/ Which is nice =D Kudos to the effort, great app.
- jrockway 14y agoInteresting. I thought I wanted something like this, but the problem with RFCs is the archaic writing style. It's hard to understand the details of a low-level network protocol when you also have to remember their redefinitions of words like SHOULD, MUST, MAY, MIGHT, PERHAPS, QUITE POSSIBLY and sort through ASCII art that is split across multiple pages. (The standards are also excessively wordy and poorly organized. And if you think the problem is just me, try finding any piece of software that actually correctly implements any RFC spec :) So basically, the all text format of RFCs is the least of their problems. But this is a nice attempt. (I wonder how many people die every year because the National Weather Service issues tornado warnings in ALL CAPS with VROUS ABREVS throughout the text. Computers can do lowercase now, guys...)
- autarch 14y agoThere's a lot of variation in the quality of RFCs, both from a technical standpoint and from a writing standpoint. I've read a number of the email and MIME related RFCs, and they're terrible. They leave out so many details, and the decisions that went into them seem designed to make email as hard to parse as possible. The HTTP RFCs have been, in my experience, better written. They just seem to be more solid. The "archaic" style is really just how you write a spec. The all-caps MUST, SHOULD, etc. stuff is about being as specific as possible. That's a good thing for a spec.
- urschrei 14y agoI agree, but that's more of an information design problem; adding an explanation of the RFC 2119 key words (or rather, the facility to provide a clear, concise explanation) would be an interesting next step, along with the ability to remove things like ASCII art. Anything beyond that is well into the realm of textual editing, and I suspect that there would be a lot of crying foul, considering that one of the main aims of these RFCs is to avoid ambiguity and the need for interpretation (certainly beyond narrow, well-defined circumstances) – never mind that as you point out, specs are never implemented "correctly".
- zobzu 14y agoRFC 2119 all the things. I write all documentation touching any subject, using the definitions for RFC 2119. Avoids a zillion of misunderstanding, and makes reading easier too.
- scrod 14y agoDid you consider processing the ASCII art diagrams in ditaa? http://ditaa.sourceforge.net/ http://ditaa.sourceforge.net/
- postfuturist 14y agoAwesome! Small, but important bug is that internal links are broken: correct link : http://pretty-rfc.herokuapp.com/RFC2616#character.sets http://pretty-rfc.herokuapp.com/RFC2616#character.sets link in text : http://pretty-rfc.herokuapp.com/RFC2616#character-sets http://pretty-rfc.herokuapp.com/RFC2616#character-sets
- mislav 14y agoThanks for reporting! I really need to improve internal linking.
- pcl 14y agoNice stuff. I'd love to see line-number ranges on hover over paragraphs / sentences, too, to support line-number-based conversations. What's this using as a data source?
- bitops 14y agoReally nice work! This will come in very handy when referencing information. If there's a way to donate to the development effort, I'd be happy to kick in a few bucks.
- samstokes 14y agoWow, the navigation sidebar definitely increases the usability of the RFCs.
- citricsquid 14y agoAs it feels relevant, here's a site of mine that includes all the HTTP Status Codes in an easy referenceable format: http://httpstatus.es/ http://httpstatus.es/
- ndrarmst 14y agoThanks for sharing! Much more convenient than Wikipedia, my usual go-to site for status codes.
- Tobu 14y agohttp://httpcats.heroku.com/ http://httpcats.heroku.com/
- samwilliams 14y agoWhile httpstatus.es seems much more functional (the short descriptions on the index are a really nice touch), this one just made my day. Thanks!
- sodelate 14y agoyour site is helpful for me,thank you for letting me know it
- aparadja 14y agoThank you so much. I've waded through plenty of unformatted RFCs this week, and this is everything I've hoped for.
- zobzu 14y agoI might be weird but I find the RFC-editor font easier to read.
- rcsorensen 14y agoI love this a lot. Minor formatting issue, perhaps. The braced formed of reference ends up losing something in the current parsing. Seeing something like "reference in RFC 1234 <a>RFC 1234</a>" jars me out of reading the document. It would be pretty neat in those cases to collapse the string so it was simply "reference in <a>RFC 1234</a>". In the cases where you can't collapse the string, to preserve reading flow, it might make sense to leave the braces surrounding the link.
- mikelikespie 14y agoDoesn't work with 6455 :(
- CasualSuperman 14y agoWould be nice if it converted lists into their <ol> or <ul> equivalents.
- karanmg 14y agoMuch easier to read. Thanks.
- hcarvalhoalves 14y agoSimple pretty hacks are the best hacks.
- mmahemoff 14y agoNow you just need to make the HTML5 specs human-parseable.
- japhyr 14y agoI notice this is a heroku app. Do you mind sharing what heroku plan you are using, and how well your setup is handling today's traffic? Have you had to do anything significant to handle a spike in traffic today?
- fbuilesv 14y agoI'm not the original author but after a quick look at the application code (https://github.com/mislav/rfc/ https://github.com/mislav/rfc/) it seems like mislav's just serving the documents from the database. It also caches the results so the free Heroku plan should be more than enough to support this.
- mislav 14y agoThe app is running on a single (free) Heroku dyno, PostgreSQL as db & full text index, and fronted with Rack::Cache using 5MB memcache for storage (also free). It survived being first on HN for hours, no probs. https://github.com/mislav/rfc/blob/74b4181/app.rb https://github.com/mislav/rfc/blob/74b4181/app.rb
- elehack 14y agoVery nice - this will make RFC reading much easier. Would be nice to have DuckDuckGo use it - will submit !bang request. Any timeframe on finishing RFC coverage? RFC 3514 isn't prettyfied yet.
- zomgbbq 14y agoExcellent use of the bootstrap css!
- porges 14y agoIt would be nice if the errata for each RFC was included somewhere - perhaps in the right margin for the relevant section?
- wangweij 14y agoI prefer the format at http://tools.ietf.org/html/rfc2616 http://tools.ietf.org/html/rfc2616. It has links and it also represents the precise original spec. The version here omits several sections and looks too dense. The link pane on the left is good.
- ryan_stevens 14y agoLame, that sites doesn't even have your standard Cat Response Codes http://www.flickr.com/photos/girliemac/sets/72157628409467125/detail/ http://www.flickr.com/photos/girliemac/sets/7215762840946712...
- xnxn 14y agoI like the idea! But... I'm just not a fan of Bootstrap's typography. IMHO, it's too dense and low contrast, especially compared to the Flask Sphinx theme (my measuring stick for beautiful, readable documentation).
- MichaelGG 14y agoFinally! I've even paid for Word documents of RFCs (hello, SIP) just to have them marked up, without the idiotic headers in the middle of each page, and hyperlinked throughout. Compared to reading some other specs (like, say, some of the SCSI ones) RFCs are just painful. Especially with the ASCII art diagrams. Now, if only the IETF could realise that "being liberal in what you accept" is a horrible idea and remove all usages of SHOULD/MAY or "infer", we'd really be rolling.
- LVB 14y ago"Read it from offical location" just sounds vulgar.
- fsniper 14y agoVery good. But search should include an indicator if the target rfc is prettified or not.
- gghh 14y agoawesome project. there is some work in progress for a duckduckhack plugin[1] on this: https://duckduckhack.uservoice.com/forums/5168-plugins/suggestions/2815972-rfc-search https://duckduckhack.uservoice.com/forums/5168-plugins/sugge... dunno, maybe those two efforts can be joined. [1] http://www.gabrielweinberg.com/blog/2012/05/introducing-duckduckhack.html http://www.gabrielweinberg.com/blog/2012/05/introducing-duck...
- goblin89 14y agoThere are EPUB and Mobipocket versions of all RFCs already available, by the way. See this thread: http://www.ietf.org/mail-archive/web/79attendees/current/msg00705.html http://www.ietf.org/mail-archive/web/79attendees/current/msg....
- telemachos 14y agoThe link to the mobi versions still works, but not the epub link. After some quick Googling I can't find a working source for them. Still, it sounds like a great resource. If anyone knows of a working link for the epub, please let us know.
- jacquesm 14y agoSuggestion: change the linked email addresses to a graphical representation. It may not help much but this lowers the barrier a bit too much for some clueless newbie to 'click on the link to email for support'. RFCs have fairly limited visibility and that's why those addresses are on there, if you significantly increase the visibility then you should probably build in a small barrier before the contact info can be used rather than to make it super easy.
- sodelate 14y agothe content page is not looking good,like the featured HTTP 1.1