3 ms·
A better explainer: https://www.clever-cloud.com/blog/engineering/2021/04/12/introduction-to-biscuit/ https://www.clever-cloud.com/blog/engineering/2021/04/12/i
by mike_d 3y ago
A better explainer: https://www.clever-cloud.com/blog/engineering/2021/04/12/introduction-to-biscuit/ https://www.clever-cloud.com/blog/engineering/2021/04/12/int...
- gnabgib 3y agoSomewhat? Browser cookies can literally contain anything (not just session identifiers, or authentication tokens), I've only heard JWT pronounced "Jay-double you-tea" (but maybe that's regional), Macaroons[0] and Maracrons[1] are French (given clever-cloud is french, this is strange), OPA doesn't need to be server side. [0]: https://en.wikipedia.org/wiki/Macaroon https://en.wikipedia.org/wiki/Macaroon [1]: https://en.wikipedia.org/wiki/Macaron https://en.wikipedia.org/wiki/Macaron
- brontitall 3y agoI think the RFC pronunciation guide > the same as the English word "jot". Only makes sense if your dialect has the cot-caught merger[0] [0] https://en.wikipedia.org/wiki/Cot%E2%80%93caught_merger https://en.wikipedia.org/wiki/Cot%E2%80%93caught_merger
- OJFord 3y agoI don't, so perhaps I'm just doomed not to understand, but I still don't get that? I would never pronounce it 'jaught' either (nor know what someone meant if they did).
- airstrike 3y agoOnly barely makes sense, you mean. And only if you squint...
- gnabgib 3y agoYou skipped an important part of the quote from RFC-7519[0] (later replaced by two RFCs[1],[2] without the strange suggestion): > The suggested pronunciation of JWT is the same as the English word "jot". Replaced by RFC-7797[1] and RFC-8725[2], neither of which have the pronunciation suggestion. There was also an errata about the pronunciation line[3], which probably explains the mismatch. [0]: https://www.rfc-editor.org/rfc/rfc7519 https://www.rfc-editor.org/rfc/rfc7519 [1]: https://www.rfc-editor.org/rfc/rfc7797 https://www.rfc-editor.org/rfc/rfc7797 [2]: https://www.rfc-editor.org/rfc/rfc8725 https://www.rfc-editor.org/rfc/rfc8725 [3]: https://www.rfc-editor.org/errata/eid5648 https://www.rfc-editor.org/errata/eid5648
- nmadden 3y agoThose RFCs don’t replace 7519, they are extensions and best practices. “Jot” is still indeed the intended pronunciation, whether you like it or not.
- thaumasiotes 3y ago> I've only heard JWT pronounced "Jay-double you-tea" That doesn't save any effort over "JSON web token".
- wtf_is_up 3y ago20% less syllables
- thaumasiotes 3y agoThose options are both 5 syllables.