6 ms·
Yes, a pigeon is faster for data transfer than gigabit fiber internet
- geephroh 3y agoTrue, but pigeon-net may also be subject to catastrophic packet loss: https://www.wnycstudios.org/podcasts/otm/segments/curious-case-50000-missing-pigeons-on-the-media2 https://www.wnycstudios.org/podcasts/otm/segments/curious-ca...
- oniony 3y agoBut you can have redundant pigeons. You can usually find a few hanging around outside the Job Centre.
- dTal 3y agoDepending, as always, on the packet size and the distance. An interesting thing to note is that according to their graph, pigeon transit time is non-linear at large distances. Obvious possible explanations include pigeon fatigue and increased potential for navigational error, but the curve seems awfully clean, possibly quadratic - perhaps an artifact of the pigeon's routing algorithm?
- tracker1 3y agoAlso worth noting that the test was using an asymmetric connection... of course this is what most have in practice at home or smaller office locations.
- geerlingguy 3y agoThe test was with two full gigabit fiber connections (verified by running iperf3 both ways, achieving about 920 Mbps in either direction, and getting 930-940 Mbps speed test.net runs.
- PreInternet01 3y agoI would like to have called your attention to the seminal RFC1149 packet firewalling using triangular buckshot paper, but unfortunately that seems to have disappeared from the visible Internetz. Shame, really...
- CobrastanJorji 3y agoJust to get all of these out of the way: * You were thinking about RFC 2549 - IP over Avian Carrier w/QoS, and its cousins RFC 1149 (the original) and RFC 6214 (IPoAC for IPv6). * The quote you were about to look up was "Never underestimate the bandwidth of a station wagon full of magnetic tapes hurtling down the highway." It was Andrew Tanenbaum, famed creator of electoral-vote.com and also some other stuff.
- gradExMachina 3y ago* shipping those drives [with black hole observation data] from Hawaii to MIT works out to 14 gigabytes per second (112 gigabits per second) https://www.extremetech.com/extreme/289423-it-took-half-a-ton-of-hard-drives-to-store-eht-black-hole-image-data https://www.extremetech.com/extreme/289423-it-took-half-a-to...
- AtlasBarfed 3y agoGood old xkcd https://what-if.xkcd.com/31/ https://what-if.xkcd.com/31/ microSD is 1TB now (actually hasn't gone up much since the xkcd, where 512GB was the practical max).
- 1-6 3y agoI still don't understand why they didn't try the same exercise with MicroSD cards. You can probably prove that carrier pigeons are faster than fiber internet for several years.
- ballenf 3y agoHe included transfer time on/off the storage medium. So MicroSD would have been a net negative. A lot of the details are in the video.
- aidenn0 3y agoMost MicroSD cards can't sustain gigabit (125MB/s) write speeds, so gigabit fiber internet is faster than micro SD cards even with a teleporter. The SanDisk Extreme Pro lists "Up to 200MB/s Read and 140 MB/s Write." This means the total speed (1 read + 1 write) is about 82MB/s which is slower than gigabit.
- agumonkey 3y agoDo the test again with nvme ssd modules, you save length (helps the bird), some weight and final destination copy, since IIRC usb3 is way slower than raw nvme.
- karaterobot 3y ago> To conclude, Geerling says he could have easily done better as PiJeff, stuffing his luggage with very high capacity drives, but wanted to stick to the common 3 TB across all alternatives. I'd love to see him explain to TSA why he's got a suitcase with nothing but stripped down USB drives and a pigeon mask in it.
- compsciphd 3y agoA couple of years ago I bought 21 14TB HDs in the US that I unboxed and packed into a suitcase (actually mostly carry-on (to give me the most control of the banging they would receive) a few were with my clothes) and brought back with me. USA had no issues with it, when I got to my destination, they required me to pay import duties on them (still cheaper than buying locally). No one gave me any problems from a security pov.
- FirmwareBurner 3y ago>when I got to my destination, they required me to pay import duties on them (still cheaper than buying locally) Lemme guess, Brasil? Don't you just love living in developing countries, where tech products required for productivity are much more expensive than in the US because of dumb duties, but wages are much lower, as pricing hardware beyond the means of the average worker definitely helps the country's economic development. /s
- jeroen79 3y agoDid they include the time it took to write the sd card?, or was the card already written?
- zamadatix 3y agoThere was no SD card, it was 5x 1 TB USB drives. Given their write speeds it would take ~100 minutes to write 3 TB to them (sequentially) and that seems to line up with the value of the pigeon line at 0 miles.
- johnea 3y agoI keep trying to get them to fetch my anime torrents, but they just keep flying off to the park and begging for bread crumbs...
- eYrKEC2 3y agoTangentially -- I keep wondering when we'll reach a point of storage size where piracy becomes "give me everything" rather than "I'd like that movie, please". When will we reach the point of being able to trivially store and copy the top 100 or top 1,000 movies from every year since the beginning of movies. Or every TV episode and movie in English, ever.
- tracker1 3y agoDepends on the resolution, compression and quality level you expect. I'm generally fine with 1080p as I don't notice the difference to 4k that much, also am generally fine with h.265 at decent compression and prefer the way it degrades (blurry background) over most others like h.264 (weird blocky background). But YMMV, my vision is not the best by any stretch, and when I was younger I'd probably notice a lot more. In this, I'll often go for movies that are <4gb and TV episodes that are under 500mb in size. I do pay for several streaming options, but often still find it easier to just hit the high seas for content. For example, Paramount+ doesn't work with my pihole, and I didn't feel like figuring out what domains they'd require me to whitelist. Edit: I had setup a relatively large NAS as I was wanting to get into Chia when it came out... that said, the first few days it became obvious I would never get a coin compared to the really big minors, so now I have a 6-drive and 5-drive raid6 array with 12tb drives. So I'm set on storage for a long while. And the Synology box supports another 5-drive expansion case to grow with. I maxed the ram, and added the 10G network card.
- paradox460 3y agoIf you use radarr and sonarr, you can kind of already do it. There are lists that give you feeds of new movies or shows, and things like Plex will alert you about new content, ready to watch
- ac29 3y ago
- MichaelZuo 3y agoConsidering the cost of a bidirectional 100 gigabit link, maintaining a flock of homing pigeons could easily be <10% of the cost, a pretty interesting choice if you don't care about latency.
- LorenPechtel 3y agoBut you have to ship the used birds back. Any given pigeon can only be used to send data to one location. Two flocks and some sort of animal-safe package delivery service.
- MichaelZuo 3y agoA single flock already implies multiple birds going back and forth?
- QuinnyPig 3y agoPigeons return home, they don’t seek out arbitrary locations.
- MichaelZuo 3y agoTrained homing pigeons do... hence why I mentioned them?
- LorenPechtel 3y agoNo. Homing pigeons return home--the coop were they were born. You take a bird somewhere, release it and it comes back to it's coop.
- MichaelZuo 3y agoHere's the first thing pops up on Google, "They had to be transported manually before another flight. However, by placing their food at one location and their home at another location, pigeons have been trained to fly back and forth up to twice a day reliably, covering round-trip flights up to 160 km (100 mi)." And judging from other sources that's pretty credible.
- LorenPechtel 3y agoStripped down USB drives??? Why not 1tb MicroSD?
- extraduder_ire 3y agoHe mentions in the video that he's including the time taken to transfer the data to/from the drives on either end. SD cards are too slow, taking as much as an extra day to copy the data on either end. These specific USB drives can saturate usb 3.1.
- bit_logic 3y agoI was thinking about a similar idea while reading the HN discussion on NASA's Deep Space Network issues. For the Artemis moon mission, instead of wasting precious DSN bandwidth, wouldn't it be better to simply store video on a hard drive and send it back to earth? That would even allow recording in full 4k. Same for things like the James Webb telescope. The latency is certainly much higher (a few days for hard drives to return to Earth and get sent back on rockets), but it seems the orders of magnitude higher bandwidth would be worth it
- branko_d 3y agoThis is a classic example of bandwidth vs. latency. You can transfer a helluva lot of data after the first byte arrives, but you’ll be waiting for that first byte for a looong time. It’s unfortunate that the words like “speed” and “fast” are often used without specifying whether that means bandwidth or latency - different scenarios often benefit from one or the other in very disproportionate ways.