6 ms·
not sure if your formatting is messed up, but these commands should work: $ sudo setcap CAP_NET_RAW+ep ./arpchat $ ./arpchat perhaps try sudo on the a
by archmaster 3y ago
not sure if your formatting is messed up, but these commands should work:
$ sudo setcap CAP_NET_RAW+ep ./arpchat
$ ./arpchat
perhaps try sudo on the arpchat binary if not
- fullstop 3y agoThat was me showing you that setcap had, in fact, been called. That's why it's the output of getcap. I tried it with sudo and it also failed with the same message. I've tried it on an arch-based laptop and a debian-based laptop with the same results.
- archmaster 3y agoi see. hmmmmm ... that's not supposed to happen, and it works fine on both nixos and ubuntu for me. may be something funky going on, i'll see if i can take a look sometime soon.
- fullstop 3y agoUsing the prebuilt binary works. Building from source does not.
- anfractuosity 3y agoBy modifying Cargo.toml slightly, I no longer got the same error, which seems to somehow relate to pnet library. pnet = "0.34.0" Interestingly with Arch it worked fine for me before, but with my Pi, I got the permission error, but changing the pnet ver seemed to fix anyway.
- fullstop 3y agoThis fixed it for me. Regarding Arch, I updated everything earlier today but I am running the LTS kernel.
- adsche 3y agoIf you use SELinux, you might want to check /var/log/audit/audit.log