4 ms·
There's a radius from earth's surface where TCP/IP won't work anymore (speed of light and whatnot). So you need some kind of datagram protocol. Also if you ne
by bb88 4y ago
There's a radius from earth's surface where TCP/IP won't work anymore (speed of light and whatnot). So you need some kind of datagram protocol. Also if you need Earth's infrastructure like DNS on Mars when Sol is in between Mars and Earth -- well, good luck I guess!
Delay/Disruption Tolerant Networking is an attempt at some of this to actually make an interplanetary protocol. Delayed routing protocols appear to be super hard -- not to mention the problem with issues with MITM attacks at the relays.
There's also interesting aspects of the space application of DTN where transmitters needing to have knowledge of solar system orbits (including the relays) to broadcast at the right time so the message will arrive when the relay is on the right side of Mars, say.
It's looks like LunaNet is going to be the solution for the Artemis mission. But the moon is only 1.3 light seconds away, so not really a super hard challenge (except when trying to transmit to the side opposite the earth). Heck, TCP will probably still work through purely analog relays, albeit terribly.
But I'm more interested in what happens for Mars missions when the round trip time is going to be measured in minutes.
- eternalban 4y ago> Delay/Disruption Tolerant Networking How interesting. (Surprised this didn't come up in IoT domain.) NASA's DTN: https://www.nasa.gov/directorates/heo/scan/engineering/technology/disruption_tolerant_networking_overview https://www.nasa.gov/directorates/heo/scan/engineering/techn... & there is something called Space Packet Protocol: https://public.ccsds.org/Pubs/133x0b2e1.pdf https://public.ccsds.org/Pubs/133x0b2e1.pdf The APID in that spec (88 bits) is where a lot of complexity (imo) is pushed up to the application layer and seems key to the archicture. It looks like basically a typed-data+endpoints addressing scheme and assigned to endpoints per mission by that mission itself.
- gnarea 4y ago> > Delay/Disruption Tolerant Networking > How interesting. (Surprised this didn't come up in IoT domain.) The term may not be commonly used there, but like everything in tech, people often try to solve the same problems from different angles using different terms. Offline First is also roughly comparable to DTN and some people in the IPFS have framed it in the context of Offline First. DTN can actually solve some of the most pressing communications issues we face today: 40% of the world population is permanently disconnected from the Internet, and many of those who are are subject to severe censorship (look up #KeepItOn).
- eternalban 4y agoI don’t know this spec but my skimming the DTN webpage and the SPP gives me the impression that this architecture is in part designed to insure end-to-end established logical circuits, so in context of [censorship/access-denial] I don’t know if it is a good fit. NASA’s HDTN [1] says it is based on IETF RFC 5050 [2]. Have to read that to understand privacy and censorship implications, specially the Bundle Security Protocol [3]. But just skimming the index in those specs reinforces my impression that this architecture can lockdown/lockout at administrative points. [1]: https://github.com/nasa/HDTN https://github.com/nasa/HDTN [2]: https://datatracker.ietf.org/doc/rfc5050/ https://datatracker.ietf.org/doc/rfc5050/ [3]: https://datatracker.ietf.org/doc/html/rfc6257 https://datatracker.ietf.org/doc/html/rfc6257 —- from RFC 6257 —- The stressed environment of the underlying networks over which the Bundle Protocol will operate makes it important for the DTN to be protected from unauthorized use, and this stressed environment poses unique challenges for the mechanisms needed to secure the Bundle Protocol. Furthermore, DTNs may very likely been deployed in environments where a portion of the network might become compromised, posing the usual security challenges related to confidentiality, integrity, and availability. -- end -- & p.s. RFC 4838 mentions "optional" security protocols (such as rfc 5050). There is also a "registration" protocol (to allow connection continuity over process restarts) "that may fail". I have to think about this but atm not 100% whether these requirements are inherent to the problem domain (overlay, mix of networks, partitions, ..)
- gnarea 4y ago> But I'm more interested in what happens for Mars missions when the round trip time is going to be measured in minutes. Same here. This is going to come across as a shameless plug, but implementing DTN tech is actually my full-time job and we've got a couple of projects that will address some of the issues you identified: - Awala, a computer network where compatible apps can use the 'standard' Internet infrastructure when it's available, or fall back to a backup medium that tolerates delays of up to 6 months. https://awala.network/ https://awala.network/ - VeraId, an offline authentication protocol powered by DNSSEC. https://veraid.net/ https://veraid.net/