3 ms·
The first SMTP RFC is RFC 788, not RFC 821. RFC 780 and RFC 772 are RFCs for MTP. IPv4 is defined by RFC 760 and RFC 791, although I don't know if RFC 760 actu
by jcranmer 4y ago
The first SMTP RFC is RFC 788, not RFC 821. RFC 780 and RFC 772 are RFCs for MTP.
IPv4 is defined by RFC 760 and RFC 791, although I don't know if RFC 760 actually implements something that looks like modern IPv4 (one of the challenges with old RFCs is that they were actually requests for comment, and I don't have a good sense of when this practice actually stopped).
I was going by Wikipedia's dates, which give the actual use of IPv4 on ARPANET as January 1983, which I believe postdates the actual use of SMTP on ARPANET.
- zinekeller 4y ago> I was going by Wikipedia's dates, which give the actual use of IPv4 on ARPANET as January 1983, which I believe postdates the actual use of SMTP on ARPANET. This is documented on RFC 801 (https://datatracker.ietf.org/doc/html/rfc801 https://datatracker.ietf.org/doc/html/rfc801), which literally just mandated use of the previous NCP until 1982 and then switch to the incompatible TCP/IP protocol stack in 1983. Imagine doing that with IPv4!