12 ms·
IP over Avian Carriers RFC 1149 event (2001)
- mothsonasloth 5y agoThere is Avian and Sneakernet, any other esoteric RFCs? I've always wondered if you could send data on migrating shoals of fish like Salmon?
- ineedasername 5y agoHere's a list of them: https://en.wikipedia.org/wiki/April_Fools%27_Day_Request_for_Comments https://en.wikipedia.org/wiki/April_Fools%27_Day_Request_for...
- can16358p 5y agoLet's see what's being added there in two days...
- deathanatos 5y agoMy favorite is RFC 6919, "Further Key Words for Use in RFCs to Indicate Requirement Levels"[1], which adds more keywords in the same spirit as MUST and SHOULD, such as, > The phrase "OUGHT TO" conveys an optimistic assertion of an implementation behavior that is clearly morally right, and thus does not require substantiation. [1]: https://datatracker.ietf.org/doc/html/rfc6919 https://datatracker.ietf.org/doc/html/rfc6919
- billpg 5y agoWhen I read that RFC, I imagined that a barcode would be more reliable to read in and process than printing the hex characters.
- jxy 5y agoTypical 1D barcode has a size limit, and the RFC is from 1990. Nowadays you could just use a QR code, which would be comfortable enough to have a 1500 MTU in a single QR code. It probably warrants an additional layer so multiple QR codes can be transmitted by a single carrier.
- _Algernon_ 5y agoLooked into using paper as an archival for small amounts of data as a long-term backup of very important data, and found this[1], which would allow encoding ~200kB of data per A4 page. Should be applicable for avian IP as well. [1]: https://blog.za3k.com/paper-archival/ https://blog.za3k.com/paper-archival/
- jkonline 5y agoInteresting, many thanks. Currently enjoying the fall down the Golay code rabbit hole. https://en.m.wikipedia.org/wiki/Binary_Golay_code https://en.m.wikipedia.org/wiki/Binary_Golay_code
- tmysl 5y agor/BirdsArentReal will definitely get a kick out of this
- ineedasername 5y agoSure, it's all fun & games when everyone is in on the joke. Just like the flat earthers, up until some musician gets into a twitter spat with Neil Degrasse Tyson over the flatness (or lack thereof) of the Earth. Only with birds, we'll have non-ironic activists burning down chicken coops and claiming the so-called "meat" we buy in supermarkets is some kind of mind control or Soylent Green, and all evidence that it started as a joke will be taken as evidence of a coverup.
- markstos 5y agoWhere the claims that meat is mind control or Soylent Green?
- ineedasername 5y agoThat was speculation of where the fledgling #BirdsArentReal movement could end up, but I'm really not serious about my criticism of the meme. As a sibling comment to yours pointed out, true believers of things like a flat earth are an extreme minority and I'm not particularly concerned that a parody conspiracy theory will cause much harm. I doubt the few true believers will be burning chicken coops any more than flat earthers are blowing up globes. (I really hope I'm not wrong about that, I do like chicken quite a bit). And we, as a society & individuals, can't and shouldn't be 100% serious about everything 100% of the time. We should be able to laugh at things, even very serious things. For example I find it pretty funny that some Russian tanks are being abducted by Ukrainian farmers w/ tractors. I can also see how deadly serious it is: It's not like they're just a few viral videos made by influencers, it's everyday people like farmers trying to take deadly resources out of the hands of an invading army.
- quinnjh 5y agoThe united states consumer protection twitter has been championing humor in this area https://mobile.twitter.com/USCPSC/status/1478844214574305282 https://mobile.twitter.com/USCPSC/status/1478844214574305282? I like your points about the necessity of humor and i think its the only way to the future for us without mass psychosis and cultural schizming. When biomorphic-engineered bird-drones can fly autonomously, and pigeons have been carrying IP for the ruling class for thousands of years, we are going to need some comedy to settle the #birdsarereal issue
- ineedasername 5y agoThe vast majority of "packets dropped" were completely unrelated to IP traffic.
- jug 5y agoThere is clearly an issue with the network protocol if the packets run the risk of starting to socialize with each other!
- deathanatos 5y ago> with ping times varying from 3211 to 6389 seconds. I guess this is a new record for ping times… Hmm, T-mobile's network comes close, but not quite that high, I think. /s Somewhat more seriously, I have seen ping times approaching 20,000 ms on their network. Given the light-distance to the moon is ~1.3 seconds, this ping clearly went significantly further than the moon's orbit, and back; very clearly some routes need tweaking. That or one hop involved a somewhat speedier avian.
- zamadatix 5y agoMore likely than moving far or moving slow the ping spent a long time being buffered at a radio lower layer retransmit where, much like Wi-Fi, having an issue sending the packet can result in multiple retries instead of an immediate drop.
- thamer 5y agoThere are some instances of real data taking much more than 6,389 seconds to travel. Voyager 2 was contacted in November 2020[1], being at the time 18.8 billion km away from Earth. Light takes about 62,000 seconds or 17h25m to travel this distance… each way! Almost a 35-hour ping. Voyager 1 is further away and still sending data, although I don't think that it has received commands for a very long time. [1] https://www.forbes.com/sites/startswithabang/2020/11/04/voyager-2-phones-home-and-nasa-still-receives-the-call/ https://www.forbes.com/sites/startswithabang/2020/11/04/voya...
- ryankrage77 5y agoIt recieved commands as recently as December 2017, when the TCM thrusters were activated. https://en.wikipedia.org/wiki/Voyager_1#Future_of_the_probe https://en.wikipedia.org/wiki/Voyager_1#Future_of_the_probe
- throw0101a 5y agoNot so funny at times: an article from 2009, "In Africa, A Pigeon Transfers Data Faster Than The Internet": * https://www.wired.com/2009/09/in-africa-a-pigeon-transfers-data-faster-than-the-internet/ https://www.wired.com/2009/09/in-africa-a-pigeon-transfers-d... * https://spectrum.ieee.org/carrier-pigeon-beats-internet- https://spectrum.ieee.org/carrier-pigeon-beats-internet-
- 29athrowaway 5y agoA truck full of storage volumes can have a higher bandwidth than fiber. Just really bad latency.
- deepspace 5y agoInteresting how the analogy progressed over the years from "a station wagon filled with tapes" to "a truck full of storage volumes". An A380 filled with micro SD cards would likely beat any conceivable fiber network in bandwidth, if not latency.
- czinck 5y agoXKCD What If kinda answered your question, although it's for the real fleets and not a specific plane, https://what-if.xkcd.com/31/ https://what-if.xkcd.com/31/. From February 2013 though, so out-of-date even if you ignore how covid has messed with shipping.
- 29athrowaway 5y agoA hyperloop full of DNA-based storage has more bandwidth than STM-1024 but less latency.
- readams 5y agoThis is roughly the idea behind Amazon snowball and similar products.
- divbzero 5y agoStrap the pigeon with 100 1TB microSD cards (~250 mg per card) and the bandwidth will approach the transfer speed of the microSD card itself — nearly gigabit speed for UHS-III cards.
- sarchertech 5y agoFunny that this would come up. This event was what inspired the last picture in a book I'm working on. In the same vein, I actually built a device once that allowed you to send http messages via black and white marbles rolling down a tube. It was very slow (and the simplest message required refilling the hopper many times). I used some drawings of an old gumball machine to design the dispenser, and I used an Arduino with a color sensor and an LED in a 3d printed tunnel to detect the marble color. I had to bury the sensor inside a tunnel with several twists and turns to block out enough ambient light to get a reliable signal. https://www.networksfromscratch.com/1.html#whats-next https://www.networksfromscratch.com/1.html#whats-next
- jkonline 5y agoI have proudly used RFC 1149s and 2549 many times over the years, (as straight faced as possible) as learning aids for INFOSEC and Help desk n00bs. Being able to introduce intentionally humorous material (that is documented within a scientific document process) has been a huge help.
- iamtheworstdev 5y agorelated: http://linux.omnipotent.net/article.php?article_id=12239 http://linux.omnipotent.net/article.php?article_id=12239.
- divbzero 5y agoRFC 1149 was updated in RFC 6214 [1] to support IPv6 but adoption has been painstakingly slow among avian ISPs. [1]: https://datatracker.ietf.org/doc/html/rfc6214 https://datatracker.ietf.org/doc/html/rfc6214
- einpoklum 5y agoHey! We'll have none of that anti-pigeon bigotry here :-P --- \ / @ ) \ _/_ |~ \) \ ( ( ( \ \ ( ( ( ( ( | \ _ _=(_(_(_(_(_(_(_ _ _ / ) - _ _ _ / _\___ ` "'
- charcircuit 5y agoDo you have a source for this? I would imagine all of them would already support it if they are in to supporting a niche such as avian messaging.
- Helloyello 5y ago
- tag2103 5y agoWhat a kinder and gentler internet we missed. I for one would support the "pigeoneer" position for my own small tech firm.