3 ms·
Open Standards enable downward compatibility, they do not prevent innovation that builds on top of them. Nothing prevents people from releasing a new RFC descr
by DocTomoe 5y ago
Open Standards enable downward compatibility, they do not prevent innovation that builds on top of them.
Nothing prevents people from releasing a new RFC describing their feature and how to implement it. See: EMail attachments (RFC 1521) which came after the original EMail definition (in RFC 822). And what you describe as "email insecurity" is just a common disagreement which encryption method to use in your MIME attachment (defined in RFC 989) - your argument sounds a bit like protesting that not everyone is using Word files when sending text attachments.
(Note: EMail metadata is deeply "insecure" and can theoretically be used to glean information about communication - but if that's your concern, maybe email is just the wrong format for you and something like encrypted messages over a network of Kafka-style message streams, ideally with lots of noise in it, would be better suited).
- 8fingerlouie 5y ago> maybe email is just the wrong format for you and something like encrypted messages over a network of Kafka-style message streams How long before the instant message formats of today becomes “the wrong format” ? Email is an open standard, and as such it should be easy to push out a new RFC that secures metadata, yet that hasn’t happened in 25+ years. I essentially agree that communication should be done over open, secure standards, but I’m not sure legislation is the right way of getting there. We will see how it all plays out.