4 ms·
Should have waited for 9001. Oh my mistake, they have several RFCs from 8999-9002.
by infogulch 5y ago
Should have waited for 9001.
Oh my mistake, they have several RFCs from 8999-9002.
- verst 5y agoFrom the article :) > The IETF just published QUIC as RFC 9000, supported by RFC 9001, RFC 9002, and RFC 8999
- 1MachineElf 5y agoHaven't heard this meme for a long time now. Reminds me of the old days when my main email was muahahaha9001@inbox.com simply to get laughs out of people. (That email service shut down roughly 5 years ago.)
- gjffkk 5y agoOver 9000!
- ucarion 5y agoYeah, they form a "cluster" of documents: https://www.rfc-editor.org/cluster_info.php?cid=C430 https://www.rfc-editor.org/cluster_info.php?cid=C430, so that the earlier-numbered RFCs can reference later ones. For instance, rfc9000 normatively refers to rfc9001 and rfc9002.
- infogulch 5y agoCurious, why isn't it numbered the other way? My programming brain is telling me that if you're reading rfc9000 you can't reference rfc9001 because it hasn't been initialized yet. :D
- anyfoo 5y agoIt's in a lot of ways more about not being defined (but possibly declared) yet, rather than initialized. You'd be super sad if you could not reference a function defined later in a source file. Yeah, I'm absolutely great at parties!
- infogulch 5y agoOk, that explanation works for me. And if there was ever an appropriate time to be pedantic it would be in a discussion on RFCs. :)
- capableweb 5y ago> You'd be super sad if you could not reference a function defined later in a source file. Would you? Most of the environments I'm in requires you to define the thing before you can use it, I'm not that sad about that. In fact, that seems to make a lot more sense than that you can define something after you use it, I'd expect that to lead to a compiler/interpreter error.
- jopsen 5y agoSo no recursion?
- capableweb 5y agoDepends on the compiler/interpreter. Function body could be parsed/evaled after the initial function definition.
- salawat 5y agoYou totally can. Remember, it's all about tokenizing. You're associating chunks of machine code to tokens that tell the machine where to go to get the actual definition, or where to plop the machine code if statically linking. Nobody said that RFC numbering implied any sort of temporal order. You are the Linker. Be the Linker.
- anyfoo 5y agoWhat environments are those?
- dzamo_norton 5y agoE.g. Python
- ucarion 5y agoPerhaps I should clarify: rfc9001 normatively refers to rfc9000 (and vice versa). There are cyclical references between RFCs, so there isn't any topological ordering. It works out because RFCs convey ideas, not code. The authors and editors take care to make sure the cyclical dependencies don't imply circular definitions or other incoherences.
- dcow 5y agoIt works in code too. It’s the difference between declaration and initialization. Very commonly existence of a symbol is declared in a header so that it can be referenced only later does the real implementation get linked in.
- snuxoll 5y agoIs QUIC really worthy of the over 9000 meme? I can’t help but feel we wasted a once in a lifetime opportunity.
- CobrastanJorji 5y agoSure, and that's one good meme. But we also get to make some HAL 9000 jokes about Google now, and that's even better (though ironic, given that it was intended to be IBM jokes).
- imhoguy 5y agoBorg vs HAL9000 - that may be an absolute blockbuster ;)