3 ms·
Looks great, However I'm getting an error while setting up: $ porter connect kubeconfig Error: code 500, errors [could not write to database]
by malobre 6y ago
Looks great,
However I'm getting an error while setting up:
$ porter connect kubeconfig
Error: code 500, errors [could not write to database]
- abelanger 6y agoApologies for the super vague error message here: this happens when the CLI is unable to read some required data from your kubeconfig or the kubeconfig contains an integration that we don't support. Mind if I ask which Kubernetes provider you use? (This comes up most often when the Kubernetes provider uses an exec-based auth mechanism). It'd also be easier to debug in our Discord if you post to the #help channel there!
- malobre 6y agoI investigated a little bit and it was a problem with certificates, the internal error message was "could not resolve kube integration (x509)". I was using a single-node k8s cluster hosted on Digital Ocean that I created myself. I'm a beginner when it comes to k8s so I ended up just provisioning from the dashboard, everything's working now :)