4 ms·
Am I the only one having issues trying to get this working? The webserver starts just fine, but once I add the index.html with zip as in the example, it stops
by safeaim 6y ago
Am I the only one having issues trying to get this working?
The webserver starts just fine, but once I add the index.html with zip as in the example, it stops working.
This is on Mac 10.15, CentOS 8 and Ubuntu 18.04 LTS.
Centos:
[centos@test ~]$ ./redbean.com -vv
error: Uncaught SIGSEGV on test.novalocal
./redbean.com
EINVAL/err=22/errno:2/GetLastError:0
Linux test.novalocal 4.18.0-240.10.1.el8_3.x86_64 #1 SMP
Mon Jan 18 17:05:51 UTC 2021
On the mac:
~ my-Maccie$./redbean.com -vv
Killed: 9
On Ubuntu:
ubuntu@localhost:~$ ./redbean.com -vv
error: Uncaught SIGSEGV on localhost
./redbean.com
EINVAL/err=22/errno:2/GetLastError:0
Linux localhost 4.15.0-136-generic #140-Ubuntu SMP Thu Jan
28 05:20:47 UTC 2021
- TeddyDD 6y agoNo, I have the same issue on Linux Mint 20.1
- r0b05 6y agoAfter adding a new file with WinRAR, I get: EINVAL/err=87/errno:2/GetLastError:203 The parameter is incorrect. Probably the ZIP needs to be saved in a certain format.
- jart 6y agoAuthor here. The zip shouldn't need to be saved in any special format. If WinRAR is posing problems then please file an issue because I'd like to fix that. That error doesn't seem like something that would indicate executable corruption. I want to learn more.
- r0b05 6y agoSure thing, will provide as much info as possible.
- user-the-name 6y agoHave to say though, using zip so you can reuse the compression is quite a masterstroke.
- adontz 6y agoIDK if this is enough https://pastebin.com/8RyPWQFf https://pastebin.com/8RyPWQFf
- xPaw 6y agoI tried to add a file using Windows file explorer, but it just complains "The Compressed (zipped) Folder is invalid or corrupted." This is on Windows 10 19042 build. 7-Zip doesn't even see the folders for that matter.
- jart 6y agoAuthor here. It works fine on RHEL5 / CentOs5 for me. I can also confirm RHEL7. Please file an issue. What will help in particular is if you can give me the faulting RIP address. That should be in the crash report or in your dmesg log.
- tromp 6y agoSame here on MacOS Catalina 10.15.7. The original invocation runs fine $ bash -c './redbean.com -vv' W2021-02-26T01:50:12.665277:tool/net/redbean.c:1144:redbean:3302] setsockopt(server, IPPROTO_TCP, TCP_FASTOPEN, &yes, sizeof(yes)) → EINVAL/err=22/errno:22/GetLastError:0 W--------------------000015:tool/net/redbean.c:1145:redbean:3302] setsockopt(server, IPPROTO_TCP, TCP_QUICKACK, &yes, sizeof(yes)) → ENOPROTOOPT/err=42/errno:42/GetLastError:0 V--------------------000022:tool/net/redbean.c:1166:redbean:3302] 0.0.0.0:8080 listen Visiting http://127.0.0.1:8080/ http://127.0.0.1:8080/ in my web browser shows a nice redbean page with lobster graphic at http://127.0.0.1:8080/tool/net/redbean.html http://127.0.0.1:8080/tool/net/redbean.html but then following usage instructions in another shell: $ echo '<b>hello</b>' >index.html $ zip redbean.com index.html adding: index.html (stored 0%) $ ./redbean.com -vv Killed: 9 I blame my zip $ zip -v Copyright (c) 1990-2008 Info-ZIP - Type 'zip "-L"' for software license. This is Zip 3.0 (July 5th 2008), by Info-ZIP. Currently maintained by E. Gordon. Addition of index.html shrinks(!) redbean.com from size 204800 to size 204348, with changes starting from char 172938. That clearly corrupts the portable executable format.
- oneeyedpigeon 6y agoYup, I get "Killed: 9" on macOS (Big Sur) too. I actually had some kind of problem (I think) with the original invocation: $ bash -c './redbean.com -vv' W2021-02-26T02:06:29.162953:tool/net/redbean.c:1144:redbean:83621] setsockopt(server, IPPROTO_TCP, TCP_FASTOPEN, &yes, sizeof(yes)) → EINVAL/err=22/errno:22/GetLastError:0 W--------------------000026:tool/net/redbean.c:1145:redbean:83621] setsockopt(server, IPPROTO_TCP, TCP_QUICKACK, &yes, sizeof(yes)) → ENOPROTOOPT/err=42/errno:42/GetLastError:0 error:./redbean.com: check failed: 0xffffffffffffffff != 0xffffffffffffffff (48) 6fffffffff70 0000004034cf UNKNOWN 6fffffffff80 000000403225 UNKNOWN 6fffffffffc0 0000004027f3 UNKNOWN 6fffffffffe0 000000402a21 UNKNOWN 7ffeefbff870 00000040227b UNKNOWN
- zimpenfish 6y agoIIRC, from vague memories of things flying past, Big Sur won't let a modified binary run once it's been checked by Gatekeeper. Which means the first run gets checked and notarised but when you add the `index.html`, the on-disk binary has changed and Gatekeeper won't allow it to run - I guess it's to prevent malicious code modifications, etc.
- jart 6y agoOh wow that's good to know. Maybe you have to do something like `cat foo.com >foo2.com` after you've modified it with the zip tool.
- safeaim 6y agoYeah, but this isn't Big Sur, it's Catalina. But maybe it's the same protection there as well? The binary didn't work on Ubuntu 18.04 nor CentOS8 either, but I'll report a issue later on today.
- anderspitman 6y agoThank goodness AAPL is here to protect us from doing cool stuff.
- oscargrouch 6y agoIts good from a security perspective, but also its a nightmare to know that the mothership knows everything you run on your machine. This will also prevent distribution from outside of their appstore giving it will prevent updates. So as anything Apple, the world security here is being used as code for personal machines remotely controlled by the mothership. You trade privacy and freedoms for a little convenience.
- zimpenfish 6y ago> This will also prevent distribution from outside of their appstore giving it will prevent updates. I think that if an app is correctly codesigned, Gatekeeper has no issue with it. Also if it's not correctly codesigned but you've ticked "allow unsigned binaries", you can still run them. > the mothership knows everything you run on your machine I can't remember the details from the last time this came up but IIRC it only sends a hash and possibly even then only the first time you launch it. Either way, they're not going to block out-of-appstore distribution except if you're a known malicious actor.
- lemniscare 6y agoYeah another killed: 9 on Mac BigSur. Could you export the tool in a way that we don't have to zip new files into it? Instead we would have to gcc the whole thing once and be done with it.
- johnx123-up 6y agoSomeone already reported the same https://github.com/jart/cosmopolitan/issues/56 https://github.com/jart/cosmopolitan/issues/56
- brabel 6y agoOn Mac Big Sur it doesn't seem to work either: ▶ zsh -c './redbean.com -vv' W2021-02-26T12:12:24.019387:tool/net/redbean.c:1144:redbean:56779] setsockopt(server, IPPROTO_TCP, TCP_FASTOPEN, &yes, sizeof(yes)) → EINVAL/err=22/errno:22/GetLastError:0 W--------------------000028:tool/net/redbean.c:1145:redbean:56779] setsockopt(server, IPPROTO_TCP, TCP_QUICKACK, &yes, sizeof(yes)) → ENOPROTOOPT/err=42/errno:42/GetLastError:0 V--------------------000023:tool/net/redbean.c:1166:redbean:56779] 0.0.0.0:8080 listen ^CV2021-02-26T12:12:27.012972:tool/net/redbean.c:1183:redbean:56779] 0.0.0.0:8080 terminated EDIT: I am an idiot: it's working just fine... the messages looked like an error to me, but visiting https://localhost:8080/ https://localhost:8080/ does show a nice HTML page!
- awestroke 6y agoDisable Gatekeeper: sudo spctl --master-disable
- snarfy 6y agoNo luck for me on win10. I can open the archive but get errors trying to add to it. 7zip and win explorer zip both fail with either unsupported or corrupted archive errors. Since it's a .com file, after downloading, win 10 also claims 'this dangerous file comes from the internet and is blocked' which you have to check a box to unblock it. I did, but still get the errors trying to add to it.
- fastball 6y agoFixed for me (macOS) in this[1] commit. [1] https://github.com/jart/cosmopolitan/commit/218ef491476f15abb980ee89bf69344913a4c51d https://github.com/jart/cosmopolitan/commit/218ef491476f15ab...