3 ms·
is there only one rfc for http? How can I find the related one's? Tried that during studying how a GET/POST etc. works and what the diff to HTTP/2 was. But I al
by kenniskrag 6y ago
is there only one rfc for http? How can I find the related one's? Tried that during studying how a GET/POST etc. works and what the diff to HTTP/2 was. But I always got a bunch of rfc's where I didn't know if they are related or already obsolete.
- dgellow 6y agoSo, it's a mess to navigate, but in general at the beginning of the RFC you have a list of other documents that update or obsolete it, and also list of documents updated or obsoleted by it. As an example: https://tools.ietf.org/html/rfc6126 https://tools.ietf.org/html/rfc6126. The document starts with "Updated by: 7298, 7557". Regarding HTTP, if you pass by the wikipedia article, you have the list of RFC on the menu on the right: https://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol https://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol. RFC 1945 HTTP/1.0 (1996) RFC 2616 HTTP/1.1 (1999) RFC 7540 HTTP/2 (2015) RFC 7541 Header Compression (2, 2015) RFC 7230 Message Syntax and Routing (1.1, 2014) RFC 7231 Semantics and Content (1.1, 2014) RFC 7232 Conditional Requests (1.1, 2014) RFC 7233 Range Requests (1.1, 2014) RFC 7234 Caching (1.1, 2014) RFC 7235 Authentication (1.1, 2014)
- kenniskrag 6y agoGreat! I didn't saw the information on top left. For example for the header compression there isn't a two way connection? I see only a reference to the http rfc.