4 ms·
Not only do dots not matter, you can suffix "+<anything>" to your user name before the "@gmail.com" and it will still come to your email address. I actually lov
by sriku 6y ago
Not only do dots not matter, you can suffix "+<anything>" to your user name before the "@gmail.com" and it will still come to your email address. I actually love this "+" feature and use it a lot .. like send an email to "+bookmark@gmail.com" to bookmark a link, or register with "+nospam" and setup a filter for that address if anyone sends me email on that.
This is supported by icloud and fastmail too.
- sydd 6y agoAlso a good check if the site has some sloppy implementation. More than once have I seen that my "+" email was not accepted because of invalid characters. I take this as a sign to not trust the site's security too.
- ben0x539 6y agoIf I were a site accepting email addresses, I could see rejecting "+" stuff because chances are it's people trying to pull something funny like registering multiple accounts when I only want one per email address. If I were less confrontational I might just silently strip the "+" part.
- wlll 6y agoSites that do any of that stuff are infuriating. Great if that's what you're going for.
- ben0x539 6y agoMy understanding is that it's okay to be infuriating if I have an analytics query or something claiming that it'll not affect 99ish % of users and also save customer support a bunch of work.
- bityard 6y agoThis is not always accidental. Facebook, for example, does not allow a '+' in your email address and you cannot tell me that the engineers at Facebook don't know about the "+" in gmail addresses. The simplest explanation is that Facebook wants to make sure you are not signing up with an alias account. That is, they want your _real_ address, just like they insist on having your real name and other personal info.
- rsync 6y ago"This is supported by icloud and fastmail too." No, this is neither supported nor not supported by any email provider - it is part of the email specification. It works that way with all email systems, unless they are non-RFC compliant.
- drdaeman 6y agoThis, to best of my awareness, is not correct. It is not a part of RFC5322, RFC2822 or RFC822 - nothing in those RFCs establish any particular semantics of local-part (the part before "@"), and in terms of syntax IIRC those RFCs only defines the escaping rules (backslashes, quotes, etc). RFC5233 mentions the established practice of using a separator character that splits local-part into "user" and "detail" pieces, but does not standardize any particular syntax for the separator (it cites "+" and "#" as possible examples). Moreover, this RFC is about Sieve language, and it is out of its scope to define such standard for email addresses. RFC3696 mentions "user+mailbox@example.com" but does not define any semantics, merely citing this as an example of a valid email address, then going to how it must be escaped in a mailto: URL. It is completely up to a particular provider to implement (or not) any subaddressing syntax and any logic related to it. No email specification I'm aware of makes this a requirement. (It's not like I've read every email RFC thoroughly, though, so I could be missing something.)
- hinkley 6y agoLots of places don't like the + in their email address validation logic. The dots are probably more reliable, but are not as flexible. The best you could do is a secret code for yourself.