5 ms·
> the term is still "master server" and "slaver server", officially Can you provide a source for this? I was using "primary" and "secondary" back when I admini
by darrenf 6y ago
> the term is still "master server" and "slaver server", officially
Can you provide a source for this? I was using "primary" and "secondary" back when I administered DNS in the mid-to-late 90s, and my recollection is that primary and secondary were always the terms in use (including in some of the originating RFCs e.g. 1033, 1035).
In fact I checked RFC1035 myself, and it specifically says:
The DNS requires that all zones be redundantly supported by more than
one name server. Designated secondary servers can acquire zones and
check for updates from the primary server using the zone transfer
protocol of the DNS.
- JdeBP 6y agoThe problem was that people overused "primary" and "secondary". They have meanings when it comes to database replication, but people then erroneously transferred that to the query resolution process, where they do not. * http://jdebp.uk./FGA/dns-database-replication.html http://jdebp.uk./FGA/dns-database-replication.html
- canadian_tired 6y agoFWIW, I used primary/secondary for years too. Once BIND 8 showed up, I think they switched to master/slave as it better described the process... to the uninitiated, "secondary" was probably viewed as a "backup" in the sensse of DR/HA.
- darrenf 6y agoInteresting. I haven't touched BIND for years and am out of the loop, plus memory is fallible anyway. Just looked at it and have ended up at RFC 8499 from January 2019: https://tools.ietf.org/html/rfc8499 https://tools.ietf.org/html/rfc8499 Master server: See "Primary server". Primary server: "Any authoritative server configured to be the source of zone transfer for one or more [secondary] servers." (Quoted from [RFC1996], Section 2.1) Or, more specifically, [RFC2136] calls it "an authoritative server configured to be the source of AXFR or IXFR data for one or more [secondary] servers". Primary servers are also discussed in [RFC1034]. Although early DNS RFCs such as [RFC1996] referred to this as a "master", the current common usage has shifted to "primary". So it seems `primary` is essentially the official term in DNS, but `master` may well be the preferred term by BIND itself.
- teddyh 6y agoThis must be a recent change, then. The latest DNS-related RFC I can find which mentions either term is RFC 8765 of June 2020, which has exactly one mention of “primary” and “secondary” each. The previous RFC which uses either term is RFC 8501 from 2018, which uses “master” and “slave” multiple times throughout. IIRC, this was changed from RFC 1035’s “primary” and “secondary” some years back into “master” and “slave”, and I think it was due to confusion with primary and secondary DNS resolvers. EDIT: I did not look far back enough to find RFC 8499 from January 2019 (7 months ago), found by darrenf in a sibling comment. This RFC apparently changes the terms again to “primary” and “secondary”.