5 ms·
If your physical hyp dies, how do you redirect your traffic to a different one?
by FreeHugs 7y ago
If your physical hyp dies, how do you redirect your traffic to a different one?
- vajrabum 7y agoLoad balancing--and yes that can become a source of failure too.
- CameronNemo 7y agoTwo load balancers using either keepalived or bgp anycast.
- gravitas 7y agoReplace "your" with "the" - the hyp can be run by your provider (Linode, DO, Vulture, AWS, GKE, whoever). Most cloud providers have virtual/shared/managed load balancers to rent time on as well, such that you don't have to maintain N+1 of those (let them do it). You could even use basic round-robin DNS, it's a possible choice just not generally suggested.
- FreeHugs 7y agoFor the load balancer solution, a lot more is needed then to just rent a load balancer. Example: What do you expect to happen when the server with your DB goes down? Just send the next UPDATE/INSERT/DELETE to DBserver2? Which is replicated from the DBserver1? When DBserver1 comes back, how does it know that it now is outdated and has to sync from DBserver2? How does the load balancer know if DBserver1 is synced again and ready to take requests? Even if you set up all moving parts of your system in a way that handles random machine outtages: Now the load balancer is your single point of failure. What do you do if it goes down?
- gravitas 7y agoRespectfully, I am not designing a full architecture here in HN comments and have not presented a full HA solution for you to pick apart. Your leading questions seemed basic, you received basic answers - going down the rabbit hole like this is just out of left field for this comment thread.