3 ms·
RFC 2046 multipart/digest A standardized method of sending a set of email messages as messages, rather than copied into body text, predates Microsoft Outlook.
by kps 7y ago
RFC 2046 multipart/digest
A standardized method of sending a set of email messages as messages, rather than copied into body text, predates Microsoft Outlook.
- ethhics 7y agoOh yes of course! Actually, multipart/mixed really seems like it should be the way that all clients do things, and that quoting at the bottom is an abuse of the quote button.
- gamblor956 7y agoIt's funny that this is a suggestion because top-posting was a reaction to the unfriendliness of keeping message history in MIME attachments rather than the body of the message. MIME may be the technically superior solution...But like Betamax and MiniDiscs, it lost out to the easier-to-use solution.
- kps 7y agoMessage history wouldn't use that; it uses headers (metadata) like 'In-Reply-To:' and 'References:', which are in… well, I was going to say RFC 822, but it turns out they go back to RFC 724 from 1977. A MIME digest would be used for the case that you want to provide someone a bunch of messages they don't already have. In that case, this brings up another reason this is superior to including the thing as text: it preserves all the threading and other metadata.