3 ms·
Also, Telnet was originally port 1 and FTP was port 3 (RFC 433, December 1972). On an incompatible protocol change (mentioned in RFC 542, August 1973), they wer
by bbanyc 7y ago
Also, Telnet was originally port 1 and FTP was port 3 (RFC 433, December 1972). On an incompatible protocol change (mentioned in RFC 542, August 1973), they were "temporarily" moved to 23 and 21 respectively until the old versions were taken down. Of course, the move back to 1 and 3 never happened.
Wouldn't FTP need three simplex connections - commands to server, responses from server, data transfer?
- sedatk 7y agoPerhaps it received command responses from the data port too.
- azernik 7y agoFTP puts data and commands on the same socket. This is perfectly doable in NCP.
- bbanyc 7y ago> FTP puts data and commands on the same socket. Not on TCP it doesn't. And some of the Arpanet FTP RFCs refer to separate connections as well, e.g. for the MAIL and MLFL commands which send email over the command and data connections, respectively. (SMTP didn't exist yet so mail was sent over FTP.)
- throw0101a 7y ago> Wouldn't FTP need three simplex connections - commands to server, responses from server, data transfer? AFAICT, per RFC 114, responses from the server are considered a data type: when a user sends a command to the server, sometimes the response is a status update ('MKDIR successful'†) and sometimes the response is the requested file. The data structure of the response has fields to say what's coming back on the data channel for the requested transaction. † MKDIR was not a command, just using it as an modern example.
- zaphirplane 7y agoAnd till fairly recently a gotcha for firewalls and when the firewall team is different from the requesting team oh the jokes