5 ms·
They currently are compatible back to 2.4. They want to drop one Python release per Django release (1.3 will support 2.5 and up, 1.4 will support 2.6 and up). 2
by koenigdavidmj 16y ago
They currently are compatible back to 2.4. They want to drop one Python release per Django release (1.3 will support 2.5 and up, 1.4 will support 2.6 and up). 2.6 is the cutoff when syntax will work everywhere.
- deleted 16y ago[deleted]
- dlib 16y agoHow are they dealing with Google AppEngine's support for 2.5 when Django reaches 1.4? Or is AppEngine also expected to upgrade to 2.6 (or higher) anytime soon?
- koenigdavidmj 16y agoThey still maintain the old versions too. Last security update featured new point releases of 1.1, 1.2, and 1.3 beta. So you can just use the old version until Google get their act together.
- varikin 16y agoTechnically, Django doesn't run on GAE. All the options to get it running on GAE involve quite a bit of hacking of Django. So there really isn't any support to maintain.
- ubernostrum 16y agoNot quite. 1.3 won't be dropping support for Python 2.4, because we can't quite do that yet.