4 ms·
The big bottleneck we had with docker containers per host was not sustained peak but simultaneous start. This was with 1.6-1.8 but we’d see containers failing t
by falsedan 7y ago
The big bottleneck we had with docker containers per host was not sustained peak but simultaneous start. This was with 1.6-1.8 but we’d see containers failing to start if more than 10 or so (sometimes as low as 2!) were started at the same time.
Hopefully rootless docker completely eliminates the races by removing the kernel resource contention.
- justincormack 7y agoRootless docker uses user namespaces it is all still happening in the kernel.