3 ms·
I don't know if this addresses everything, but from the spec: 1.5. JSON as the Data Encoding Format JSON is a text-based data interchange format a
by jerf 7y ago
I don't know if this addresses everything, but from the spec:
1.5. JSON as the Data Encoding Format
JSON is a text-based data interchange format as specified in
[RFC8259]. The Internet JSON (I-JSON) format defined in [RFC7493] is
a strict subset of this, adding restrictions to avoid potentially
confusing scenarios (for example, it mandates that an object MUST NOT
have two members with the same name).
All data sent from the client to the server or from the server to the
client (except binary file upload/download) MUST be valid I-JSON
according to the RFC and is therefore case sensitive and encoded in
UTF-8 [RFC3629].
RFC-7493: https://tools.ietf.org/html/rfc7493 https://tools.ietf.org/html/rfc7493
A quick scan of it says to me it doesn't get all the issues but it does get the biggest one, which IMHO are the ambiguities in what constitutes a "number" in JSON. I-JSON explicitly limits it to 64-bit floats.